More Runscript problems

Essentially, I get this error:
2004-06-11 14:53:53.776 runscript[12749] Trapped Signal 10 -- Attempting To Terminate
2004-06-11 14:53:53.776 runscript[12749] Trapped Signal 10 -- Attempting To Terminate

It tends to happen when I attempt to run the 'runscript' command twice in a row. I have a bash script that runs nightly, which calls runscript on one script, does a 'wait' until it is finished, sleeps for 10 seconds to ensure everything has had time to shut down, then calls runscript again.

I get a few steps into the second script, when it dies with the error above.

Any thoughts on this? The script I"m calling is a parent script that then calls a number of scripts in order to run individual tests. But I can't reproduce this issue with a small number of tests ... if I comment all but one test from each script and run, it seems to work.

Chris.

Comments

  • EggplantMattEggplantMatt ForumAdmin admin
    It looks like Eggplant is crashing for some reason. You'll need to send some more information directly to [email protected] in order for us to begin diagnosing the problem. You can send the crash logs to us by launching Eggplant in GUI mode (be sure you're logged in as the same user that was running it from the command line) and selecting "Report a Bug..." from the Help menu. This will create a new e-mail addressed to support with the crash logs attached. You might also send along the shell script that you are using to call the scripts.

    You say that you get a few steps into the second script; is the crash coming at a consistent point in the second script? Can you send also send us a results log that shows where the script execution ended?

    Once support receives these materials we'll be in a better position to address this issue.
  • camcam Member
    Thanks. I'll do that.

    Chris.
Sign In or Register to comment.