Vine Server 3.0 does not keep SSH setting in System Server

RobKRobK Member
When I setup a System Server via the Preferences in Vine Server 3,0, I use these settings:

Authentication : None (ie NO Password)

Require Remore Login (SSH): Checked

Then I start the system server.

But when I go back to the Preference for the System Server, "Require Remote Login (SSH)" is UNCHECKED!

Is this a known bug?

Did my original system server start in a state where a SSH connection was required?

Comments

  • RobK wrote:
    When I setup a System Server via the Preferences in Vine Server 3,0, I use these settings:

    Authentication : None (ie NO Password)

    Require Remore Login (SSH): Checked

    Then I start the system server.

    But when I go back to the Preference for the System Server, "Require Remote Login (SSH)" is UNCHECKED!

    Is this a known bug?

    Did my original system server start in a state where a SSH connection was required?

    I think the true meaning of "require remote login" is that it limits
    the Vine Server to listen only on the "localhost" interface
    (IP 127.0.0.1). You can test if this is the case using the command

    sudo lsof -i

    in a Terminal window, and noting whether OSXvnc references
    localhost or not.

    In my case I've got it required (with a password), and it works fine,
    and is maintained in the settings. I'm using Vine Server 3.1 beta,
    which you should be able to find with a forum search.
  • JonathanOSXJonathanOSX ForumAdmin admin
    Yes, that is a small bug in VS 3.0 -- its fixed in 3.1Beta
  • RobKRobK Member
    nospamboz wrote:

    In my case I've got it required (with a password), and it works fine,
    and is maintained in the settings. I'm using Vine Server 3.1 beta,
    which you should be able to find with a forum search.

    Well it looks like this annoying bug has been fixed in 3.1 (see post the follows yours).

    I tried to locate the 3.1 Beta on the forums but could not find it. I guess I will have to wait for the 3.1 release.
Sign In or Register to comment.