Fast user switching problem (Vine Server 3, Leopard)

I have two users set up, both at 1024 x 768. User A is automatically logged in. If I try and fast user switch to User B, then the system server shows a garbled display (see attached jpg)

Interestingly though if I log out and log in to the other user it works fine (though the login resolution is much larger than 1024 x 768 and the VNC session is reset on both logout and in)...

Anyone have any ideas?

Thanks

Comments

  • JonathanOSXJonathanOSX ForumAdmin admin
    Does that condition happen all the time? I've seen it occur on occasion but usually doing a Fast-User-Switch does present a usable screen through VNC.
  • Yes, I am familiar with that torn screen image (somewhere along the way the correct resolution of the screen is lost).
    I can reproduce it reliably (in fact, I cannot get around it for the use I am trying to make).

    I am running a current model Mac Mini with OS 10.5.5 and Vine Server (same problem with both 3.0 and 3.1b2). This mini is headless -- no display, keyboard, or mouse -- just connecting through LAN with VNC. I am trying to get it to boot up and setup several logged in users (using Vine Server and fast-user-switching) so I can have multiple users connected simultaneously.

    When I first boot up, the display is fine via vnc and I can log in. However, whenever I fast-user-switch, the "System Server" instance of Vine Server goes to that unreadable torn image and no amount of fiddling, logging in/out, or fast-user-switching will repair it. Only a reboot will set it straight again.

    If the first user to log in runs their own local Vine Server, that screen is fine, too, and it stays good after I do a fast-user-switch (which makes the System Server screen go bad). However, if the second user (the one being logged in by fast-user-switch) also runs their own Vine Server instance, that screen is bad, too. So, I can get more than one user logged in, but never more than one is accessible with a viewable screen via vnc.

    Now, if I plug in a physical display (vanilla VGA monitor with the Apple-supplied DVI to VGA converter) everything works perfect. So, that led me to try shorting out the monitor ID pins on the VGA connector, instead of plugging in the actual display, like we used to do with old macs to trick them into booting up headless. But that didn't help any.

    Anyone have any ideas for how to get this headless, multi-user server going?
  • I actually solved this with a hardware hack - use a 100 Ohm, 5% tolerance resistor (brown, black, brown, gold) across green and ground as shown here:

    http://blackfriarsinc.com/blog/2007/04/how-to-keep-headless-mac-mini-happy

    I prefer using the DVI-VGA convertor (easier to switch in and out) in which case its pin 2 to pin 5 (see http://pinouts.ru/Video/VGA15_pinout.shtml). Seems to work fine.

    This keeps the mac happy by tricking it into believing a monitor is present, and as a side benefits gives you lots of different resolutions to play with and your desktop background back.

    I went to the trouble of opening up an old vga plug and soldering the resistor inside. It was an interesting project but if i'm honest an utter pain. For that amount of trouble, if you are bothered about how it looks its probably worth buying a specialist dongle such as Dr Botts gHEAD2 or griffins macPNP.

    Just annoying how the Mac Mini is too clever for its own good.

    Cheers
  • Ok, great. I'll give that a try.

    So, was this the same problem that was causing your torn display image the other day, and now shorting the green video signal has solved it for you? Or do you have another source of the same symptom and are still looking for a solution?
  • Same problem - this fixed it, thought i'ld post back on results for everyone else.

    It's obviously something to do with the behaviour of OSX when no monitor is attached rather than Vine as it works perfectly when it has one (or thinks it has one!).

    I haven't tested just shorting out the 2 pins rather than using a resistor - but that might be where you're going wrong?

    Cheers
Sign In or Register to comment.