Example of launching OSXvnc-server from command line

Could someone please post an example (preferably sticky) of how to launch the Vine Server from the command line. I used to do this over SSH before using the viewer rather than leaving the server running all of the time, but now I get an "Incompatible Version" error when I do it this way (it still works if I launch the server from the Finder.)

Thanks.

Comments

  • JonathanOSXJonathanOSX ForumAdmin admin
    First, make absolutely sure you are connecting to Vine Server and not ARD or another server (that's usually what incompatible server means).

    Second you need to be sure you specify either a password file (-rfbauth FILE) or the -rfbnoauth if you want to let clients login with no authentication.
    /Applications/Vine\ Server.app/OSXvnc-server -rfbnoauth
    
  • I don't want users to connect without authentication. I am certain it is Vine Server. I have no problems connecting when I launch VNC Server from the Finder. Until recently I had no problems when I launched VNC Server from the command line using PuTTY. The only thing unusual I see is the message "Unable to get session dictionary" but I don't know if that's new or not.

    Using username "userid".
    Using keyboard-interactive authentication.
    Password:
    Last login: Mon Nov 24 12:40:17 2008 from proxy3e.swmed.edu
    the-mac-mini:~ userid$ /applications/vine\ server.app/osxvnc-server
    2008-11-24 12:50:13.012 osxvnc-server[43375:10b] Arguments:
    2008-11-24 12:50:13.021 osxvnc-server[43375:10b] Main Bundle: /applications/vine server.app
    2008-11-24 12:50:13.024 osxvnc-server[43375:10b] Loading Bundle /applications/vine server.app/Contents/Resources/TigerBundle.bundle
    2008-11-24 12:50:13.027 osxvnc-server[43375:10b] Loading Bundle /applications/vine server.app/Contents/Resources/JaguarBundle.bundle
    2008-11-24 12:50:13.033 osxvnc-server[43375:10b] Running in Little Endian
    2008-11-24 12:50:13.035 osxvnc-server[43375:10b] Pasteboard Inaccessible - Pasteboard sharing disabled
    2008-11-24 12:50:13.036 osxvnc-server[43375:10b] Waiting for clients
    2008-11-24 12:50:13.036 osxvnc-server[43375:1e03] Using Private Event Source
    2008-11-24 12:50:13.038 osxvnc-server[43375:1e03] Unable to get session dictionary.
    2008-11-24 12:50:13.039 osxvnc-server[43375:1e03] Using Dynamic Event Tap -- Session for off-screen user
    2008-11-24 12:50:13.041 osxvnc-server[43375:1e03] Registering Bonjour Service(_rfb._tcp.) - the-mac-mini.local
    2008-11-24 12:50:13.042 osxvnc-server[43375:3303] IPv6: Started Listener Thread on port 5904
    2008-11-24 12:50:13.044 osxvnc-server[43375:1e03] Started Listener Thread on port 5904
  • JonathanOSXJonathanOSX ForumAdmin admin
    Ok, if you went them to have to authenticate you have to use the -rfbauth FILE argument to specify a password file.

    You can make a password file with the storepasswd tool found in the same location.
  • pjparkpjpark Member
    edited November 2008
    It looks like AppleVNCServer was taking up the port 5900. Your answer plus

    sudo /System/Library/CoreServices/RemoteManagement/ARDAgent.app/
    Contents/Resources/kickstart -deactivate

    did the trick.

    Thanks!
  • JonathanOSXJonathanOSX ForumAdmin admin
    You can disable that in System Preferences->Sharing->Screen Sharing. Unfortunately there is no way to move Apple Remote Desktop off port 5900.
  • I edited my previous reply instead of posting a new one. Your answer plus

    sudo /System/Library/CoreServices/RemoteManagement/ARDAgent.app/
    Contents/Resources/kickstart -deactivate

    did the trick.

    Thanks!
Sign In or Register to comment.