Too many security failures...

So I fixed my previous problem that I was having with vine server not responding by just using the system server and having it running 24/7.

I connect via my iphone, however, after a little while I get a "too many security failures" when trying to connect. Ive never had any auth issues, and every time I get this error I have to restart the server before I can connect again.

The viewer-client I am using is called "Jaadu VNC"

Would running the server with no password fix this problem? I would rather not do this for obvious security reasons, but I can't figure out how to fix this.

Thanks!

Comments

  • EggplantMattEggplantMatt ForumAdmin admin
    Please look for this error in the FAQ: http://www.testplant.com/phpBB2/viewtopic.php?t=569
  • Hi, i checked the faq before posting and I only noticed this post pertaining to realVNC servers:

    Q: After attempting a few connections to a RealVNC Server, I get a "Authentication Failure - Too many security failures" error, only rectified by a restart of the RealVNC server, or reboot the remote system. Why does this occur?

    A: "Auth Failure" occurs when a client has "hit" a RealVNC server too frequently without a successfull login (it is on a timer and will eventually expire) there are some things you can do to mitigate it.

    1) Make sure you have password entered into the connection properties (EDIT) prior to initiating the connection.
    2) Make sure that in preferences you have availability polling set to OFF, or once at startup.

    This is primarily a "feature", more like a bug, in RealVNC logic where they consider ANY port traffic on the VNC port as a failed login attempt even prior to a password being supplied. We have looked at supplementing our port polling logic with a more sophisticated port scanner (half-connect attempt) but it's a fair bit of work and doesn't guarantee success. The real issue should be dealt with at RealVNC with configuration file support allowing attempt number configuration/specification, allowable time before blocking, or completely turn this feature off in secure known deployment environments.


    However, like I said, my password has been correct every time and Ive never had an authorization failure. In fact, my password is actually stored in my client.

    Even so, I am using Vine Server, and not realVNC. Does Vine server have that same "polling" thing, and if so, is there a way I can turn it off?

    Thanks!
  • JonathanOSXJonathanOSX ForumAdmin admin
    Vine Server should only log that error if you actually ARE making multiple attempts to connect and failing. If you want to disable that behavior you can add
    -maxauthattempts 0
    
    to the Command Line Arguments (under Preferences->Advanced).

    It does make me wonder if Jaadu is doing something strange or if someone else is trying to hit your VNC server and trying to log in -- you might consult your Vine Server log.
Sign In or Register to comment.