Using a hot key Macro with Eggplant doesn't work properly

So here is the problem I created a Macro and have it hot keyed to ctrl + alt + shift + c on a XP. I am then connected through VNC to that computer and running a script. At one point in the script I use the hotkey with TypeText and the macro is supposed to move a scrollbar very precisely which is what I need(but it doesn't move precisely). My problem is that if I manually do it on the XP the macro moves the scrollbar perfectly eveytime and the result is what I am looking for. Unfortunately when I use the TypeText function in Eggplant with the hotkey the Macro never behaves properly on the XP. Is there any way to deal with this in Eggplant. Does it have something to do with Eggplant maybe somehow retaining control a little bit. I am not to sure what is causing this and hoping there is a solution or setting that will allow me to deal with this issue.

Comments

  • SenseTalkDougSenseTalkDoug admin ForumAdmin admin
    Is your macro not executing? Or is it executing but not producing the expected result? The first thing I'd check in this case is to make sure that you are properly invoking your macro, and releasing all of the modifier keys. If you invoke your macro like this you should be okay:
    TypeText ControlKey, WindowsAltKey, ShiftKey, "c"
    
    If you use any "...Down" keys instead (like "ControlDown"), then be sure to release them (by typing "ControlUp", etc.), otherwise those modifiers will be left down during your next actions on the SUT.

    Assuming the macro is executing but not doing what you want, you didn't say what sort of actions you think Eggplant might be taking that would cause your scrollbar to be positioned incorrectly (additional keystrokes? mouse movements?).

    Eggplant generally doesn't do anything with the SUT other than what your script tells it to do. But there are a couple of cases in which Eggplant will move the mouse without being explicitly told to. The first is when searching for an image. If the image isn't found Eggplant will move the mouse to the bottom corner of the screen before it gives up on finding the image. This can be turned off by changing the ShouldRepositionMouse global property:
    set the ShouldRepositionMouse to false
    
    The other case involves a tiny wiggle of the mouse (as described in this post). You can disable it like this:
    set the wiggleMouseAfterTyping to false
    

    If none of those ideas help, perhaps you can describe your situation in more detail.
Sign In or Register to comment.