Eggplant pauses on execution

While executing the script eggplant pauses eventhough the image is visible/exists,can any suggest if there is any way to avaoid this.

Comments

  • EggplantMattEggplantMatt ForumAdmin admin
    If eggPlant says it can't find an image, then either the image on the screen is different in some way from the captured image, or you have a timing issue (the image is appearing, but only after eggPlant has already stopped looking for it.) Diagnosing timing issues is described in the the Using Eggplant manual. If you don't think it is a timing issue, you can send the captured image and a screenshot that you think it should match to the TestPlant support address and we can tell you why it is not finding the image.
  • The pause happens for a loop which iterates through on various values,below script is where i m facing this issue

    set the defaultLineDelimiter to empty
    put file "D:\iStay2-Eggplant_Script\Controller\Controller.csv into controller
    repeat with ctrlr_line = each line of controller
    if item 2 of ctrlr_line id "Y" then
    put item 1 of ctrlr_line into ActionScript
    run ActionScript
    else
    next repeat
    end if
    end repeat

    could you please provide a solution on the same
  • EggplantMattEggplantMatt ForumAdmin admin
    Have you accidentally set a breakpoint on that script? Is there a little arrow in the left-hand margin where the pause is occurring? If so, you can remove it by dragging it out of the column or by selecting the "Remove all breakpoints" option from the Run menu. If this is the problem, the breakpoint was placed there when at some point you clicked in that column.
  • Yes,thanks for your help :)
Sign In or Register to comment.