Script stopping after executing one line of code

Sometimes Eggplant won't execute the code correctly. One minute it works, and then the next minute, I can't get it to behave the way it just did. Here are some screenshots of the code/results.

In picture 3 (attached), you can see what happens when I run the selected function from run.script. The results panel shows that it can successfully find the start button, but it never clicks it.

If I change the second line in the click.start function to simply click "start", then I get the same result. (see 'Picture 5') (and yes, I remembered to save the 'click' script). This happens with all methods, not only those in click.script.

This happens to me frequently. I come back a week later, and it no longer occurs. I then work on eggplant stuff for an hour, and it breaks again.

Please help. thank you.

Comments

  • EggplantMattEggplantMatt ForumAdmin admin
    The problem is that you've named your script "Click", so it's overriding (i.e., replacing) the built in Click command. The "Click" commands inside your Click.start handler call the Click script, which does nothing -- it has no initial handler, that is, no code before the handler definitions. We've noticed that you've also got a script called "Run", which is also a SenseTalk command that that script will override.

    One other thing we see is that you are using the "Do" command unnecessarily. Where you have:
    Do "Click" & startLocation + (x, y)
    
    you can instead just call the command:
    Click startLocation + (x,y)
    
Sign In or Register to comment.