Problems with ImageDoctor in Auto mode

Hi all,

I have a script that is trying to find a small image, an Icon in a toolbar, when the image was captured the monitor that was attached to the machine was old so resolution was different than it actually is now.

I have set the ImageDoctor to Auto, so that it tries to fix discrepancies automatically. When Running the ImageDoctor Manually, I'm able to "detect" the image i'm looking for, but when running from the script, it does not.

Am i misunderstanding something about how should the auto doctor work? I have attached a couple of images so you can more clearly see what's going on, any help in this matter would be much appreciated.

Thanks,

Luis R. Rojas

Comments

  • EggplantMattEggplantMatt ForumAdmin admin
    I've looked at your images and I'm not sure why there would be an issue because the icon in the screen image is nearly the same as the icon in the captured image and all of the pixels are well within tolerance of the search type. So the Image Doctor, automatic or otherwise should not be coming into play. Does the icon perhaps first appear in the disabled state and then become enabled more than 8 seconds later?

    It doesn't look like the automatic Image Doctor is kicking in. It should mention it in the Run window output when the image is not found initially, so it's not that the image isn't being found by the Image Doctor, it's that the Auto Doctor isn't getting run.

    If you could please send the actual captured image and the complete script output from the results folder that would be helpful.

    One note: The resolution of the monitor has no bearing on the execution of scripts except where the monitor doesn't display as much of the screen as when the script was captured. EggPlant is resolution independent because screen resolution is just a function of mapping the virtual pixels of an image to the physical pixels of the monitor. EggPlant always looks at the virtual pixels, which are unaffected by the screen resolution.
Sign In or Register to comment.