Running OSXvnc-server directy

Hi,

Running Lion 10.7.2
and have installed the 4.0 beta

I am trying to run OSXvnc-server directly from a script, so I don't have to run Vine server and perform clicks (as I have only remote access to the device)

Using the following params
./OSXvnc-server -rfbport 5900 -rfbauth vncpass -alwaysshared -localhost -ipv4

All starts fine, but when I connect it gives me the following errors
2011-12-12 13:24:12.368 OSXvnc-server[431:707] Pasteboard Inaccessible - Pasteboard sharing disabled
2011-12-12 13:24:12.369 OSXvnc-server[431:707] Waiting for clients
2011-12-12 13:24:12.369 OSXvnc-server[431:2b03] Using Private Event Source
2011-12-12 13:24:12.370 OSXvnc-server[431:2b03] Unable to get session dictionary.
2011-12-12 13:24:12.370 OSXvnc-server[431:2b03] Using Smart Event Tap -- Session for off-screen user
2011-12-12 13:24:12.371 OSXvnc-server[431:2b03] Started Listener Thread on port 5900
Dec 12 13:26:16 Romans-MacBook-Pro.local OSXvnc-server[431] <Warning>: CGDisplayBaseAddress is obsolete and returning NULL for display 0x0
2011-12-12 13:26:16.956 OSXvnc-server[431:2b03] Unable to obtain base address
Dec 12 13:26:17 Romans-MacBook-Pro.local OSXvnc-server[431] <Warning>: CGDisplayBaseAddress is obsolete and returning NULL for display 0x0
2011-12-12 13:26:17.457 OSXvnc-server[431:2b03] Unable to obtain base address
Dec 12 13:26:17 Romans-MacBook-Pro.local OSXvnc-server[431] <Warning>: CGDisplayBaseAddress is obsolete and returning NULL for display 0x0
2011-12-12 13:26:17.958 OSXvnc-server[431:2b03] Unable to obtain base address
Dec 12 13:26:18 Romans-MacBook-Pro.local OSXvnc-server[431] <Warning>: CGDisplayBaseAddress is obsolete and returning NULL for display 0x0
2011-12-12 13:26:18.460 OSXvnc-server[431:2b03] Unable to obtain base address
Dec 12 13:26:18 Romans-MacBook-Pro.local OSXvnc-server[431] <Warning>: CGDisplayBaseAddress is obsolete and returning NULL for display 0x0
2011-12-12 13:26:18.962 OSXvnc-server[431:2b03] Unable to obtain base address
Dec 12 13:26:19 Romans-MacBook-Pro.local OSXvnc-server[431] <Warning>: CGDisplayBaseAddress is obsolete and returning NULL for display 0x0
2011-12-12 13:26:19.464 OSXvnc-server[431:2b03] Unable to obtain base address
Dec 12 13:26:19 Romans-MacBook-Pro.local OSXvnc-server[431] <Warning>: CGDisplayBaseAddress is obsolete and returning NULL for display 0x0
2011-12-12 13:26:19.965 OSXvnc-server[431:2b03] Unable to obtain base address
Dec 12 13:26:20 Romans-MacBook-Pro.local OSXvnc-server[431] <Warning>: CGDisplayBaseAddress is obsolete and returning NULL for display 0x0
2011-12-12 13:26:20.467 OSXvnc-server[431:2b03] Unable to obtain base address
Dec 12 13:26:20 Romans-MacBook-Pro.local OSXvnc-server[431] <Warning>: CGDisplayBaseAddress is obsolete and returning NULL for display 0x0
2011-12-12 13:26:20.969 OSXvnc-server[431:2b03] Unable to obtain base address
Dec 12 13:26:21 Romans-MacBook-Pro.local OSXvnc-server[431] <Warning>: CGDisplayBaseAddress is obsolete and returning NULL for display 0x0
2011-12-12 13:26:21.471 OSXvnc-server[431:2b03] Unable to obtain base address
Dec 12 13:26:21 Romans-MacBook-Pro.local OSXvnc-server[431] <Warning>: CGDisplayBaseAddress is obsolete and returning NULL for display 0x0
2011-12-12 13:26:21.972 OSXvnc-server[431:2b03] Unable to obtain base address -- Giving up


Eventually it dies.
However when I run the vac from within the Vine server window, all works ok.

What am I doing wrong ?
Thanks in advance

Comments

  • I have been able to run OSXvnc-server by making a LaunchControl plist for it. I looked at how Vine calls the program to use the same arguments as much as possible. This works, but unless you really want to remotely start and stop the server it is much simpler to start the System Server in Vine.
    <xml>
    <DOCTYPE>
    <plist>
    <dict>
    <key>Label</key>
    <string>com.testplant.vncserver</string>
    <key>OnDemand</key>
    <false>
    <key>RunAtLoad</key>
    <true>
    <key>ProgramArguments</key>
    <array>
    <string>/your/path/to/OSXvnc-server</string>
    <string>-rfbport</string>
    <string>5901</string>
    <string>-rfbauth</string>
    <string>/your/path/to/passwordFile</string>
    <string>-swapButtons</string>
    <string>-nevershared</string>
    <string>-donotloadproxy</string>
    <string>-restartonuserswitch N</string>
    <string>-keyboardloading n</string>
    <string>-eventtap 3</string>
    <string>-eventsource 2</string>
    </array>
    </dict>
    </plist>
    
  • thx a lot.

    However that did not help. Apparently the problem is that I need to run it off the dmg downloaded. If copied does not work anymore.
Sign In or Register to comment.