Image Search on iPad 3 fails

Hi,
I captured a small "delete"-button on iPad3 and want to run "click Btn_delete". Unfortunately when running this single line EggPlant clicks somewhere else, but not on this image. I can see the orange frame shortly appear in an area where there is no button or anything similar, but there is no failure message.
With Image Doctor I get good values, but all attempts like "Fix image"; "Recapture Image", capture as Text Image failed. I tried multiple Images from wider frames to small frames just surrounding the circle.
Image Doctor is confusing me with the mesage "12 found", but the Magenta and red and blue results are all on the one image.
Please have a look at the attached image.
Any help would be appreciated.

P.S. with the results of Image Doctor, what would be your choice ? Original and then "Fix Image" ?

Comments

  • EggplantMattEggplantMatt ForumAdmin admin
    There's not enough information in your post for us to be able to diagnose this issue. We need to know what the current search settings for the image are (as shown in the image Info drawer) and where on the screen the image is actually being found. A full screen shot of the iPad would be helpful. My suspicion would be that during a previous run of the Image Doctor an overly tolerant option was selected that is now causing the image to match in the wrong place, but that's just a guess.

    It actually looks like it's finding your image in the right place using the current settings. This makes me wonder if there is some window animation taking place; if a window/panel/control slides onto the screen or makes some other animated entrance, eggPlant will often find an image when it first appears and before it reaches its final destination. Once the image is found, that's where the scripted action is going to occur. So when your click is executed, eggPlant will start looking for the close button. If the close button first appears on the screen on the left edge as the window slides into view, that's where eggPlant is going to target when it clicks. The image may continue on to another position after eggPlant finds it, but unless your script accounts for that, then it's going to be clicking in the wrong place. Let us know if this description matches your scenario and we can provide you with some code to handle waiting for the element to reach it's final destination.

    When a search type in the Image Doctor indicates that it found something multiple times, but you see only one rectangle indicating that location it is often that the area matched is sort of a cloud of pixels that match and the upper-left corner of the matching area can be placed in any of several contiguous positions. You should see a thicker border on the rectangle when this happens because of the multiple side-by-side matches.

    As for what choice you should make based on the Image Doctor results, there are a number of dependencies that go into that decision. If it's identifying the image in the correct location using a different Tolerance setting, then I would choose Dynamic Tolerance and then "Fix Image". If it is finding it only with the discrepancy setting, then I would make a collection using the "Add representation" option. There's a video that tries to explain the use of the Image Doctor at http://www.testplant.com/support/2011/05/how-to-use-the-image-doctor/; you might want to watch that if you haven't already done so.
Sign In or Register to comment.