Abort puts eggplant into a bad state

I accidently clicked the "Run Script" command instead of the "Run Selection". Not a problem until I clicked the "Abort" command.

The script happened to have a couple of layered repeat loops (repeat loop inside of another repeat loop).

When I clicked the "Abort" button the connection to the SUT was broken, the Abort button never resets back to the "Run Selection" No further runs can be initiated.

Sometimes the application becomes so locked up that all windows and and screens are locked. In this case I have to kill the app by logging in from another workstation and kill the eggplant process. Once I do that I can restart eggplant and everything is back to "normal"

Comments

  • JonathanOSXJonathanOSX ForumAdmin admin
    This shouldn't normally occur. Having multiple layers of repeat loops should have no impact on the ability to abort (and then restart) a script. Neither should "Run Script" vs "Run Selection".

    The fact that the connection dropped at precisely that time makes me wonder if there is a race condition of some sort.

    What version of eggPlant are you running and what is the VNC server you are connecting to?
  • I am using Eggplant 11.3 on a Linux platform

    Setup:
    Logged into Linux workstation
    rsh to the eggplant server
    su to a common username
    set display back to my Linux workstation
    run a VNC server on my Linux workstation
    set up a connection to use my Linux workstation as the common user

    Additional information:
    I have two repeat loops with numeric limits (repeat 7, repeat 6)
    When an object is found in the inner loop I do an exit repeat at that point. This only exits the inner loop. Sometimes the outer loop would continue and other times it would stall. When it stalled I noticed shortly afterward that the connection to the SUT was broken.

    I would get the same problem if I tried to "Abort" the script while it was inside of the innermost loop. This is where I originally saw the problem.

    When the disconnect occurs the abort icon remains and does not reset. If I try to "Quit Eggplant" the workstation locks up. I have to kill the eggplant application froma a remote terminal. If instead of using "Quit Eggplant" I kill the application the workstation does not lock up.

    Since then I have added a flag to the inner loop that is passed to the outer loop to exit the outer loop. I have had 3 successful runs with this flag so far.
  • EggplantMattEggplantMatt ForumAdmin admin
    If at all possible, you should upgrade to v12.1. That issue may no longer exist, and the only way we could provide you with a fix is via a new version.
Sign In or Register to comment.