Keyboard at login not working.

Hey all!

I've been trying to run Vine system server on 10.7.x and 10.8.x so that I can login while no one is using it. As connection is made I do get the login screen and the mouse works (I'm able to click restart, shutdown, etc) unfortunately when I click on the text field to enter a user's password I get nothing. And nothing appears on the remote computer's text field as well.

I've googled this with no luck. Even started playing with Vines keyboard and hardware settings. Nothing. If someone is logged in and I try to connect to Vine keyboard works perfectly.

On a login note, is it normal for Vine to disconnect after a user has logged in? Found it strange that built-in vnc doesn't have this "issue" (I'm guessing Apple's private magic calls are in play.)

Thanks for your time! Any help would be greatly appreciated!

Comments

  • It appears this is a very specific issue. If more information is need I'll gladly provided it ASAP.

    Any help or to be pointed in a certain direction would be great.

    [UPDATE]
    Found interesting details in the log. Think they are related:
    OSXvnc-server[104]: 3891612: (connectAndCheck) Untrusted apps are not allowed to connect to or launch Window Server before login.
    OSXvnc-server[104]: Window Server is not available
    

    Thanks again!!
  • JonathanOSXJonathanOSX ForumAdmin admin
    It is normal for Vine to disconnect when you log-in.

    As far as the "not trusted" behavior, that should only happen if you don't use Vine's System Server to register for startup. If you use that it should be trusted.
  • I've encountered EXACTLY the same behaviour in the latest version. Whenever I reboot my machine remotely, and it comes back up to the login screen, I can see the screen, and move the mouse, but I'm unable to enter either the username or password. If I get my wife (who is at home...) to login for me, I can then get in fine. Also, if the screen locks, I am then able to unlock it. It's literally only the initial login that causes issues.

    Very odd!
  • Thanks for your reply JonathanOSX!

    Not sure what is meant by:
    you don't use Vine's System Server to register for startup


    I use the GUI app and select the start system server. Enter my credentials and all should be good, right?
  • Any update on this?

    I am having the same problem, I cannot enter my password in the Login screen if OSX is logged out when I connect.

    Interestingly, if I connect to the built-in OSX VNC screen-sharing utility, it does allow me to enter my password. I can then disconnect from that and connect back to Vine once I am logged in, then it works fine.

    Is there any way of authorising Vine to be able to be used in the Login screen, just as the native VNC utility is?
  • I have this problem as well. Using an X11 vnc client, server is a 10.9.2 mac. Everything works fine except keyboard input on the login screen.
  • Hm, OS X Mavericks built-in VNC seems to actually work fine with linux clients. So, problem kinda-solved.
Sign In or Register to comment.