Can't connect eggplant to SUT through VNC.

Hi,

total newbie here. I'm actually just testing to see if eggplant will be able to automate some of our testing, so I know nothing about it or about VNC. I find the directions lacking in the manual so I run into this problem. When I try to connect the my SUT, I either get a message "Too many security failures" or "The server is not configured with a supported authentication type." Not sure what to do here. Does anyone have an idea and/or is there a step by step list of what configuration steps you are supposed to do to ensure connection? The VNC server is version 5.1 and the directions on the site do not quite coincide with what I see on the screen.

Comments

  • Hello Margaret!

    The authentication type is something that you'll set in your VNC Server on the SUT (system under test). It sounds like you are using RealVNC. See the attached image for steps to get to the authentication type settings in RealVNC. The image is showing RealVNC running on Windows, but the settings should be in the same location on Mac when you open the server.

    You'll need to set the Authentication type to "None" and the Encryption to "Prefer Off".

    Let us know if you still have trouble after that!
  • eggElizabeth,

    thank you! Although my configuration screens in VNC server look a bit different, I found the settings and made them what you had in your image and I was able to connect.

    Thanks again!

    M
  • Hi,

    I am having the exact similar issue. I am unable to connect even though the VM has the settings like you have shown in the screenshot here. Encryption and authentication is OFF.


    whatelse can I do?

    EPUser01
Sign In or Register to comment.