TypeText issue...

Hi all,

I'm having a strange problem with TypeText command and special buttons (alt, ctrl, win...). Even though I'm able to perform the copy, paste operation w/t any issues (TypeText "\c" & "c" & "\C" etc.), I wasnt able to simulate the Win button.

I've found that there's a special character for that - w for button down and W for button up, but I still can make it work.

When I run this line TypeText "\w" & "\W" simply nothing happens on the SUT. And yeah, I've tried this also: TypeText windowsDown, windowsUp ... Run screen says that the script run is a SUCCESS, but I dont see the win start menu poping up on the SUT...

Any thoughts on what may be the cause of the problem? Is there something in Eggplant 'Preferences' that I need to configure?

Thanks, :)
Ivan.

Comments

  • clisscliss Member
    What type of operation are you trying to achive in the AUT? If it's to minimize the window and on Mac try TypeCommand "w".

    Charles
  • EPJoKEPJoK Member
    If you are using TightVNC try using Realvnc instead. Some of the keystrokes will not work with TightVNC.
  • IvanIvan Member
    I'm trying to open up the 'Start Menu' on windows, but without having to record the image of course.

    I'll definitelly try out other VNC server&client, because at the moment I'm using WinVNC for the server and the default client for Eggplant (should be TightVNC, if i'm not mistaken).

    Thanks for the quick response, I'll play around with VNC... I'll let you know what happend.
  • clisscliss Member
    Okay if you are trying to open the start menu the typecommand should work. The Command key on mac and the Windows key are the same.

    ~CL~
  • IvanIvan Member
    cliss wrote:
    Okay if you are trying to open the start menu the typecommand should work. The Command key on mac and the Windows key are the same.

    ~CL~

    Actually... the command key on Mac is 'Alt' in windows ;)

    I've tried 'TypeText' with \w and \W (like Eggplant Reference.pdf says), but it doesn't work. Also, I've tried 'TypeCommand', same story...

    Hmm... it still might be an VNC issue...
  • IvanIvan Member
    Hi people,

    Has anyone tried out the TypeText "\w" & "\W" on Windows SUT machine? Anyone??

    Eggplant people?

    Thanks,
    Ivan.
  • EPJoKEPJoK Member
    TypeText "\w\W"
    

    ...Seems to work find against RealVNC 4.1.2. I have noticed that it doesn't work with TightVNC 1.2.9.

    Have you tried RealVNC?
  • IvanIvan Member
    Woohoo! Works on RealVNC...

    Thanks, EPJok! :)
Sign In or Register to comment.