Color mapping over VNC

I've been evaluating Eggplant for a couple of days, and have been quite impressed so far. But I just changed the configuration of my SUT and uncovered a new problem.

My primary SUT is a VMWare instance of Windows XP. Until today it was running on a slightly-outdated version of VMWare Workstation, with the latest version of TightVNC installed on the virtual machine. I had to keep RDesktop running in order to use the mouse on the VNC connection, but other than that glitch the setup was fine.

Today the same instance was transitioned to the much-more-robust VMWare Server, which has a built-in VNC server. When I connect to that server with Eggplant as a client, the color map is wrong... the default-blue background looks orange, and everything else is similarly shifted.

I tried connecting with Chicken of the VNC, and it does *not* show the color shift (everything looks correct). Thus it seems to be an interaction specifically between Eggplant's VNC client and VMWare Server's VNC server.

I tried disabling all of the available VNC encodings except the one that the server was using, for each of Hextile, Z-RLE, and RRE; none showed any change in the color map.

I've seen no mention of this behavior elsewhere in the forums. If anyone has seen it before, or can suggest further troubleshooting steps, I'd really appreciate it.

--
Lex Nemzer
QA Lead
MetaCarta, Inc

Comments

  • I'm running a similar setup to the above poster. I'm connecting Eggplant to the internal VNC server provided by WMware Workstation 6.04.

    The VNC connection runs ok, but the colour mapping is shifted and not displayed correctly. I have the Eggplant VNC connection set to 'millions of colours'.

    If I connect using RealVNC then the correct colour mappings are shown.

    Any ideas gratefully received.
  • SenseTalkDougSenseTalkDoug ForumAdmin admin
    Try changing the Color Depth setting for your connection. In particular, I suggest trying the "Default" setting, which will try to use whatever setting Eggplant receives from the server rather than requesting a particular depth.

    We don't usually recommend this choice for Eggplant, because it's important to keep our view of the remote screen consistent across different runs, but it may be the right choice in this case.
  • HI SenseTalkDoug - yup that fixed it. Many thanks for the suggestion.

    BTW Using Eggplant in conjunction with VMware like this is immensely flexible and powerful. Because the VMware VNC component runs in the Workstation and not the VM I can run tests into the SUT VM even before the VM has networking started. Very useful for my company the delivers WinPE based products.
Sign In or Register to comment.