Require SSH doesn't work for me

cesjrcesjr Member
I was able to get Vine Viewer on my powerbook connecting to Vine Server on my Mac Pro, on a local network and over the internet. And I was able to do it using SSH with password authentication.

But then I decided to make it more secure and use keys (and disable password authentication). I used SSH Helper to set this up. It works great, on my local network and over the internet. I can use Vine Viewer and Vine Server, with the keys.

The only problem - admittedly a small one - is that if I checkmark "Require SSH" in Vine Server, the VNC connection stops working. I guess it doesn't matter much because I have set up my firewalls and port forwarding such that a port 22 connection is the only one possible (no port 5900 access to the Mac Pro), still I find it odd that I can't select this option in Vine Server.

Comments

  • JonathanOSXJonathanOSX ForumAdmin admin
    This can happen if, in your Vine Connection Settings, your SSH Host and your Server entry don't match exactly. (Or you can also correct it by setting the Server value to be 127.0.0.1 while leaving the SSH Host in place).

    The Server feature that allows only local connections means that the packets must literally be coming in through the local interface, not just resolving to the same machine.

    The SSH forwarding is a very powerful feature, it actually allows you to use the SSH Host as a gateway machine to reach machines that aren't even publicly addressable (meaning the names are resolved on the local network).

    This normally works great but adds the complexity that you see here.
Sign In or Register to comment.