can't start Vine Server on port 80 or 443. Macos X

Hi,

I am running Macos X 10.4.8 on an macbook pro.

When I attempt to start the server I get the error

Vine Server can't listen on the specified port (443).
Probably because another VNC is already using this port.

I can start the server fine on some +1000 port, such as 1234.

I have tried ps -aux and used grep to look for apache, tomcat, httpd, anything else that looks suspicious. I can't find anything that would be taking port 80 or port 443.

Is there another way of finding out what is using a port? Is there any other reason Macos X would not let an application use a port?

thanks

- James

Comments

  • SenseTalkDougSenseTalkDoug ForumAdmin admin
    The message that suggests there is probably another VNC server using that port is somewhat misleading. Ports 80 and 443 are assigned for use by HTTP and HTTPS -- they are almost certainly in use by your web server (usually apache).

    For VNC, the usual port to use is 5900, or occasionally another port in the 5900-5999 range. It is strongly recommended that you use one of these ports. The Vine Server will use port 5900 by default (also known as Display number 0), or, if you set the Display Number to "Auto" it will choose the first available port in the 5900+ range.

    Unless you have a very good reason to use some other port, choosing one of these options will be the simplest route to VNC happiness. :-)
  • Problem is grepping my process list reveals no apache in use!
    http://localhost:80 and http://localhost:443 do not yield results. I'm pretty sure there is not any web server running there.

    I'm basically trying on ports 80 or 443 because I want to get through a firewall I'm not allowed to modify. I could probably sort this out seperately, but I'm trying to keep my solution as simple as possible.

    The other strange thing is that I can not find any free point around 443. I'm wondering if I lack the security privilages on my machine to start any servers that listen on 'low ports'.

    Problem is, I don't know what a 'low port' is, and my user is running as a system 'Administrator', - so I don't know how I can give a GUI application more privilages. (there is no sudo from the finder).
  • JonathanOSXJonathanOSX ForumAdmin admin
    Yes, the problem is that ports below 1024 may ONLY be used by ROOT. Although an administrator can validate for certain operations he is not running everything as root. The Vine Server application doesn't perform an authentication request for a User Server.

    However, the System Server, is installed and runs AS root. So if you go to the startup tab and "Start System Server" with the current configuration set to port 80 or 443. Then you should be able to get it going.
Sign In or Register to comment.