Setting up VNC with an AirPort Extreme

dcalfinedcalfine Member
Vine is a great tool. I've been using it to access computers from another room for months and it's really handy. Now I want to take it to the next level, but can't. My modem is hooked up via DHCP to an AirPort Extreme. I then have an AirPort Express, that, through WDS, relays the signal to my computer. I've tried to set up port forwarding and all that, but it just doesn't work. Can anyone tell what's wrong with my settings?

Pic_Sharing.jpg
Sharing

Pic_Access.jpg
Remote Desktop Access Privileges

Pic_Server.jpg
Vine Server Settings

Pic_Connection.jpg
What I'm typing into Vine Viewer

Pic_Mapping.jpg
My Port Mapping settings for AirPort in AirPort Admin Utility

Pic_Refuse.jpg
And then the message that comes up in Vine Viewer when I try to connect

Any ideas?

Thanks in advance,
David

Comments

  • JonathanOSXJonathanOSX ForumAdmin admin
    It looks like everything should be good. Just some quick notes

    1- It's on 5901 so you need to specify that in the Connection (it's unclear if you did or not).

    2- I can't tell if you are running the firewall on the Mac machine, if so make sure port 5901 is open.

    3- You do not need to enable ARD's Server and Vine Server, we recommend JUST running Vine Server.
  • Okay, I've disabled all the Apple Remote stuff in Sharing and have temporarily disabled the firewall, but I'm still getting the same "Connection Refused"

    For what it's worth, the alert is almost instantaneous. It doesn't seem like it's going across the internet and back. But honestly I have no idea.
  • I've tried something new. I've stated the port as in the address as well. I think this was what you were talking about.

    Anyways, it still doesn't work, but I get a different error message:
    Pic_Error.jpg
  • SenseTalkDougSenseTalkDoug ForumAdmin admin
    I don't think you want to add the port number onto the IP address.

    Are you connecting to your external IP address? Keep in mind that the IP address that's visible to the rest of the world is different than the one you'll typically use to connect within your local network. If you go to http://www.portforward.com you'll see your external IP Address displayed near the bottom of the page. That site also has great information about setting up the port forwarding through various routers, although it sounds like you've got most of that figured out already.
  • I've done exactly what they say to do here: http://www.portforward.com/english/routers/port_forwarding/Apple/AirPortExtreme/OSXvnc.htm

    but it keeps saying that the connection was refused

    that's only when i connect through the external IP. When I connect through my LAN it works fine.
  • JonathanOSXJonathanOSX ForumAdmin admin
    That all seems exactly correct. The only thing I can guess is that your external IP isn't routing properly (from inside your network, out the router and then back in through the AirportExtreme).

    Or possibly that your ISP is blocking traffic in this port range (unlikely but possible), you might try following the instructions for enabling SSH and connecting through SSH.
Sign In or Register to comment.