Preconfigured VineServer?

mbmb Member
We are looking for a support solution for our Macintosh customers via VNC and would like to offer a preconfigured client, already set-up with the correct host and port for a reverse connection. Can this be done with vine server by providing some config files within the app folder, a script starting the app with the corrcet parameters or the like? Starting the included macosVNC with the -connectHost parameter via terminal gives no visible evidence for the customers of what is happening, starting vine server the same way appears to ignore this option.

Comments

  • JonathanOSXJonathanOSX ForumAdmin admin
    Sorry for the delay, busy times.

    This has been discussed before and we hope to offer an easy config option in the forthcoming Vine Server to allow for this sort of configuration/customization.
  • mbmb Member
    Thanks for your reply. Any ideas already, when the new version will be available?
  • JonathanOSXJonathanOSX ForumAdmin admin
    The new version should be available Monday, Dec 17th.

    There is a Beta version available now but it does not include the "pre-configure option". Schedules permitting we may put another beta out before then that does include that feature.
  • JonathanOSXJonathanOSX ForumAdmin admin
    Vine 3.0 is out and this feature IS included.

    If you look inside the Vine Server.app there is a file at Contents/Info.plist.

    This is an XML file that has blank entries for ReverseHost and ReversePort. If ReverseHost is populated with a resolvable host name or IP address then Vine Server will issue a connection invitation when the server is started.
  • I tried the instructions above but it is not populating the reverse connection field or starting a reverse connection. I am using Vine Server 3.0. It works fine if I manually add the connection. Below is what the text of the XML file looks like after I modified it.

    <key>ReverseHost</key>
    <string>xxxx.xxxx.com</string>
    <key>ReversePort</key>
    <string>5500</string>

    Maybe I am entering the text wrong.
  • I just realized client has to click "Start Server" and then everything works just fine.

    Thanks for adding this feature it's great.
Sign In or Register to comment.