Strange behavior with Vine and Leopard

I have been using VNC through SSH for a long time on linux, even windows with Cop SSH and OSX 10.4 using Vine to start a "system server". It worked great.


Since going to leopard, it seems there are multiple problems.


If I VNC from my linux or PC using "VNC VEIWER" www.realvnc.com or Tight VNC viewer into Leopard, the VNC session will lock up whenever I copy something to the clipboard on the client.

This happens on a new install of Leopard 10.5.1 and Leopard Server 10.5.1



Strange problems with Authentication when Require Remote Login SSL only is selected.

No matter which password I use, I get rejected ( when going through the SSL tunnel) but when using the local IP the password is accepted.
(Yes, I am running only one server on port 5900)
If I remove the password option, I can then SSH in from through the tunnel.


If I remove the option Require Remote Login (SSH), and put back the password info I can then log in through the ssh tunnel.



Lets forget about Vine and SSH. Lets just talk about the buit in VNC server on Leopard.


Is anyone else having these problems?

Comments

  • JonathanOSXJonathanOSX ForumAdmin admin
    Hang when copying to clipboard
    We are not seeing that problem here with Vine Server on 10.5.1. We _do_ see that problem when working against the built in server. Can you see if it only happens with certain settings or with certain kinds of paste operations?
    Is this problem only with the System Server? Do you have the same problems with the Desktop Server?

    Problem with Require SSH checkbox and System Server
    There is a confirmed bug with this checkbox and the System Server, it has been fixed for the next release (3.01).
  • Hang when copying to clipboard
    We are not seeing that problem here with Vine Server on 10.5.1. We _do_ see that problem when working against the built in server. Can you see if it only happens with certain settings or with certain kinds of paste operations?
    Is this problem only with the System Server? Do you have the same problems with the Desktop Server?

    Problem with Require SSH checkbox and System Server
    There is a confirmed bug with this checkbox and the System Server, it has been fixed for the next release (3.01).

    Thanks for your reply.

    Can I try 3.01?

    I stopped remote management on the server and installed Vine. It no longer freezes when copying and pasting.
    It also works well through SSH. When require SSH was checked, I was not able to get in using the LAN IP.

    Pass word.
    Unless I have the password set to none, I am unable to authenticate with or without Require SSH checked.
    Is this something you can replicate?

    One last question. What is the best way to make Vine start as a "service"? To have Vine running at the login screen.

    Thanks again.


    Why Apple just didn't choose implement Vine in the first place is beyond me.
Sign In or Register to comment.