International Keyboard problem

Hello

The config:
I'm using Vine Server with a machine with a French keyboard, in System Server mode,, and controlling it from a XP Machine with a French keyboard also.
I use it in "Keyboard Layout: current" and "Keyboard Events: Smart events mgt" mode.

Now the problem: I can't type any "i" at all. The event is never seen, never got on the server side. Unlike an other poster below, it doesn't generate a "command+i" event, it doesn't generate anything at all. All other keys/events are fine.

If I change the keyboard layout on the server to US, then the "i" comes back; but I can't type any "?" more. So I have constantly to swap between layouts.

I've tried to change to "Hardware events" or "User session events", that doesn't make any difference.

Any idea ?
Thanks

Comments

  • JonathanOSXJonathanOSX ForumAdmin admin
    This is indeed a problem with the current loading of French Keyboard, we should have a beta for a fixed server available very shortly.
  • This is indeed a problem with the current loading of French Keyboard, we should have a beta for a fixed server available very shortly.
    OK thanks

    BTW: This problems exists with FR, Swiss-FR, Canadian FR and Belgian keyboards.
    The only one that I found letting me type both the "i" and the "???.." is (curiously) the Italian-Pro one.... No idea why, but it works
  • I have a similar problem, except this time it's with the Finnish keyboard layout.

    There are three problems I am experiencing:

    1) Pressing the "o", ")" and "?" keys cause no character to appear on the screen.

    2) Pressing the "?" key causes the "o" to appear.

    3) Using AltGR and 9 causes the "}" character to appear when "]" should appear.

    Using AltGR also seems to throw the layout completely, causing special symbols to appear, although as I'm new to Mac's I'll put that down to user error.
  • After further testing with a Finnish keyboard, it seems that the closest I can get to a fully mapped keyboard without strange wingdings characters appearing is to set "keyboard Events" to "User Session Events".

    The OS/X keyboard viewer also revieals that when "?" is pressed, the "o" button flashes. Yet strangely when ? is pressed, the ? button flashes, giving the correct symbol.

    The problem with the ) seems to be that when 9 is pressed, it is mapping to the numeric keypad 9 and so SHIFT+9 does nothing. For all other numbers, this is not the case.
  • RalleRalle Member
    Hello,

    I have exactly the same problem, with german keybordlayout and the
    little "b" - Key. The big "B" works fine.

    Is there an update for this Problem, or an workaround ?

    I work remote with a WinXP-PC on my iMac with Leopard and the Vine-Server. I am otherwise very content with Vine.

    Greetings from Germany, Ralle!
  • JonathanOSXJonathanOSX ForumAdmin admin
    A Beta Version of Vine Server 3.1 is available that we hope eliminates this problem. Please download it, try it out and post your results:

    Vine Server 3.1Beta
  • renedrened Member
    Version of Vine Server 3.1 is available... that we hoped didn't eliminate this problem....

    Tried this beta doesn't work much more with i key...
    sorry,
    Ren?. ?
  • RalleRalle Member
    edited March 2008
    clear, doubble
  • RalleRalle Member
    Ok, thanks for the very short support reaction time.

    At first, the little 'b' Key works fine. Now I can use the German key board layout outstanding.

    There are some spezial keys with no function. I write this fact, but its not a great problem without this keys!

    alt gr 'E' is the sybol for EURO, don't work
    al gr '?' is '⁄' but Vine write one of this both |\\\\\\\|\|\\|||\||\\|||\\|||\\\\\\\|\\\\
    '^' don't work
    `?` (right from ?) don't work

    Those are not large problems. I hope that it helps you to find out the beta as desired functioned.

    Greetings, Ralle!
  • I'm running the 3.1 beta (1018) on Mac OS X 10.4.11. I'm using the German keyboard layout on both the Mac server and the Windows client. I'm connecting via RealVNC 4.1.2.

    The following keys don't work for me:

    b ? ? ? ? ? ?
    Shift + ? = ?
    Shift + ? = ?
    Shift + ? = ?
    Shift + 3 = ?
    Shift + ^ = ?
    Alt Gr + E = ?

    "Smart Event Management", "Hardware Events" and "User Session Event" don't really make a difference for me, except that the latter two cause a 3 digit code `\ddd` to be displayed instead of the not working key, while the first one seems to execute some weird sequence of keys.

    I noticed some improvements versus 3.0 and I hope you'll be able to fix the remaining issues too.

    Stephan
  • HarpoHarpo Member
    Sorry for the reaction time.

    I second "rened": the problem with the French keyboard is not solved in the latest beta.
  • JonathanOSXJonathanOSX ForumAdmin admin
    We've just posted an updated Vine Server Beta that we hope addresses this problem. Please read this notice -- http://www.redstonesoftware.com/phpBB2/viewtopic.php?t=1206
  • Hello, now that this international keyboards issue is in process, let me report that VineClient has a a few problems with the Spanish keyboard.

    Specifically I have executed xev in the server to obtain the keysyms that the server receives and VNCViewer makes the following mistakes with the Spanish keyboard:

    Alt_L pressed sends the sequence Shift_L pressed,Meta_L pressed, Shift_L released (only Alt_L pressed must be sent in this case)
    Alt_L released sends the sequence Alt_L released (this case works properly)
    Cmd_R pressed sends the sequence Alt_L pressed (AltGr (aka Alt_R or ISO_Level3_Shift) pressed should be sent in this case because the macintosh Spanish keyboard doesn't have the AltGr key and there is not any other way to send this key)
    Cmd_R released sends the sequence Alt_L released (AltGr (aka Alt_R or ISO_Level3_Shift) released should be sent in this case because the macintosh Spanish keyboard doesn't have the AltGr key and there is not any other way to send this key)
    The tilde key (used in ?,?,?,?,? in Spanish) is ignored by VNCViewer, that is, it is not sent to the server.
  • Regarding my previous post. I HAVE FOUND A PARTIAL WORKAROUND to deal with these keyboard issues with VNC Viewer. On wishes that the redstonesoftware will solve the above keyboard issues sometime in the future.

    First of all, Xvnc (the VNC server) receives keysyms (instead of keycodes) from the VNC viewer. So it is an unsuccessful effort to do changes in the /etc/X11/xkb/ configuration files.

    Fortunately Xvnc has the -RemapKeys option. We can remap keysyms by using this option in this way:

    $ vncserver -RemapKeys='0xffe7->0xfe03'

    In this example I'm remapping the Meta_L key (AltLeft in my iBook G4) to the AltGr key (which doesn't exist in my iBook G4).

    If you have a Linux VNC server, you can use the xev tool of the X Windows to obtain the keysym that corresponds to each key of the keyboard.

    Now that VNC viewer seems to be usable and the best one on the market, it is my time to by a license.

    Unfortunately, this workaround deals only with the AltGr problem. Nonetheless, this workaround doesn't solve the tilde issue (?,?,?,?,?) since the tilde is a deadkey and remapping other key as the tilde produces "?a" instead of "?".

    It seems that the only solution is by getting access to the VNCViewver source code: Specifically, by catching the tilde key along with the subsequent vowel key "?a" in the VNCViewer and sending the combined keysym "?" to the VNCServer.
  • gruvgruv Member
    Im on a swedish keyboard and the letter "o" dosent work for me.
Sign In or Register to comment.