SSH VNC Client OSX

pdtpdt Member
Hi,

all of our customers are accesable only via ssh.

So we configrued Vine Viewer 1.x properly and all was running flawlessly. So we updated to the release 3.0 to suport the developers.
But with version 3.0 we cannont connect any mor and we had to switch back to 1.4

On 3.0 we get the message "no authentication needed" and the symbol of the connection is partially green and yellow. And we cannot establish the connection any more.

No way to get 3.0 runnig the same way as the 1.4x??

TIA

Uwe

Comments

  • JonathanOSXJonathanOSX ForumAdmin admin
    Can you give us a little more detail about the server environment? Are you connecting to Vine Server 3.0? If so, make sure that you configured the Vine Server to either have a password or explicitly chosen No Authentication.
  • Our servers are all Suse Linux Enterprise Servers in release 9 and 10.

    We are using the standard vnc server integrated in X-Window and KDE!

    As I know there is no further configuration needet on servers side. Vine 1.4 rans without problems and only the new release 3 gives us such problems!

    But I can mail you the appropriate vnc config file. But I think the error istelf lies on the ssh side???


    TIA


    Uwe
  • JonathanOSXJonathanOSX ForumAdmin admin
    Yes, go ahead and send those logs to [email protected]
  • Hi,

    I stumbled into this forum searching for a solution for the same issue.

    I'm using Vine Server 3.0 running on MacOSX 10.5.2.

    Tested Clients:
    Debian Lenny, KDE, krdc
    Windows XP Pro, putty and Ultra VNC Viewer 1.0.4 (Security Update 2)

    Windows in running inside a VMware on that Debian Machine.

    Both clients are able to connect to the vncserver as long as no ssh login is required:
    krdc server:5900

    If ssh login is not required and I use:
    ssh -L 6666:mac:5900 [email protected]
    even:
    krdc localhost:6666
    connects me to that mac.

    If I turn ssh on connections is not allowed. :cry:

    Am I missing anything?

    Thanks

    Cornald

    Edit: UltraVNC tells me: "Error reading protocol Version." Mabe this is helpful
  • Sorry for spaming the forum but I consider this as important:

    I ssh'ed into the mac and typed:

    tail -f /var/log/secure.log

    on opening another terminal session i typed:

    ssh -L 6666:mac:5900 [email protected]

    this gives me:
    Feb 18 23:24:44 mac sshd[1152]: Accepted keyboard-interactive/pam for user from 199.XXX.XXX.XXX port 1029 ssh2
    

    As soon as I try to open a vnc-session on localhost:6666 I get in secure.log:
    Feb 18 23:25:04 mac sshd[1156]: error: setsockopt TCP_NODELAY: Invalid argument
    

    I googled a bit but only found apache errors.

    Can somebody confirm this?
Sign In or Register to comment.