TypeText isn't always accurate :-(

So I am using the TypeText command for various password testing along with time entry. My problem lies with Eggplant sometimes entering the shifted characters instead of the lowerecase ones. For example a time entry could look like either:

11:20am or
!!:@)Am

This is pretty frustrating. I have tried adding delays to see if it gets in too much of a hurry, but this hasn't seemed to change the outcome. Any thoughts?

Thanks,
Ben

Comments

  • Kinda wild, kinda weird, kinda typical. Just make sure you do not do a "TypeText shiftKey", and also depends on the version of the EP you are using. The newest releases claim to be releasing the modifier keys after the TypeText command is done. Its a mystery to me if that actually is the case.
  • Hmmm I am using FT 4.1

    This is not beu?o at all. I wonder if there is a way to slowdown the typing. might give Eggplant enough time to figure out what it nees to do correctly.
  • JonathanOSXJonathanOSX ForumAdmin admin
    First you do want to make sure that you aren't doing a ShiftKeyDown in your script without making sure you have a ShiftKeyUp that goes alongside it. Or better still use the newer "ShiftKey" which will always be released at the end of the line.

    But I'm not sure that this is an Eggplant problem and not a VNC server problem. Which VNC server are you connecting to?
  • After checking this morning I am using Vine3.0 for OS X 10.4.11

    I tried slowing down the typing with no avail. It seems that after Egpplant runs for a couple days it can develop a communication problem with the SUT, it will start to block up the picture until I restart Eggplant, perhaps its just the need to reset the connection.

    Thoughts?
  • JonathanOSXJonathanOSX ForumAdmin admin
    If you are using VNC on a dedicated SUT (meaning the SUT isn't the same machine) then please try adjusting the Keyboard Layout and Keyboard Events setting in Vine Server as shown here:
  • Hey Jonathan,

    I am testing your solution right now and it is alot better, but not perfect. Soon as I have a greater number of trials I am will report back.

    Thanks so much for your assistance.
  • JonathanOSXJonathanOSX ForumAdmin admin
    Just wanted to followup and see if this is working reliably for you now. If not let us know and we'll continue to investigate; but we want it to be running flawlessly.
Sign In or Register to comment.