Mac TIG issue

I am facing the same problem with following command for finding some of the menu items on Leopard.

eg:
Click(Text:"Utilities",TextSize:14,TextBackgroundcolor:(211,211,211))

Comments

  • EggplantMattEggplantMatt ForumAdmin admin
    Open the Appearance preference panel in System Preferences on both the Eggplant machine and the test machine and make sure that the Font Smoothing Style setting is the same on both systems (you should restart both Eggplant and the test app after doing this). Please note that even if your SUT is a second user on the Eggplant machine, a setting of "Automatic" is not adequate -- you must select one of the other smoothing styles. In the future we'll be releasing a standalone TIG for the Mac that will run on the SUT and make this discrepancy less of an issue.
  • User1User1 Member
    Still facing the same problem after setting Font Smoothing Style as "Medium - Best for flat panel" on both the user(Eggplant and SUT) on Leopard Intel Mac. And also let me know when you are planning to release standalone TIG
  • EggplantMattEggplantMatt ForumAdmin admin
    Is the image you posted scaled? It appears to be smaller than normal menu text (we can't used scaled images for troubleshooting). Are you having trouble finding just the Utilities menu item, or are there others? Also, are both machines running the same version of the OS?
  • User1User1 Member
    No, I have not scaled but may be it is due to IMac resolution (1024x768). I have checked with 1280x1024 also but facing the same problem. I am facing problem with "Item" and "Utilities" only others are working fine. Yes, I have Client(Eggplant) and SUT on same machine (Leopard OS).
  • EggplantMattEggplantMatt ForumAdmin admin
    The problem that you're having is not because of the machine resolution; Eggplant is resolution independent. But the menu image that you posted is an odd size and I'm not able to match against it. Unless you're doing localization testing, there's no reason to use the TIG against the menus -- it would be better to use standard image capture for text that it isn't changing dynamically from run to run.
  • User1User1 Member
    I think you were right, previous image was scaled. Please try with this:
  • Your second image, when zoomed, clearly shows an LCD setting with sub-pixel alignment (see attached), whereas the one you posted earlier did not. I set my Eggplant and SUT machines to turn this off - System Preferences->Displays->Color and use Generic RGB.
  • User1User1 Member
    Is separate TIG is available for Mac?
  • JonathanOSXJonathanOSX ForumAdmin admin
    That TIG is in active development but is not yet available, you'll be able to check for it (and other TIGs) on the downloads page.

    Active customers who have expressed an interest will be given the chance to beta test the TIG.
Sign In or Register to comment.