NSMallocException error

I also encounter the same problem when I try to capture an image: NSMallocException:
Attempt to allocate 2097152 bytes for NS/CFData Failed.

Will the following command to resolve this problem:
defaults write com.redstonesoftware.Eggplant SaveThumbnails -bool FALSE

And how to enter this command.

Please let me know what went wrong. I was told that this is related to permission setup problem. Is that right?

Thanks!

Comments

  • EggplantMattEggplantMatt ForumAdmin admin
    You would enter the defaults write command in a Terminal window (the Terminal app is found in /Applications/Utilities), but I'm not certain that this error is related to creating thumbnails. Is it happening repeatedly?
  • Yes, this problem is repeatable. I reboot the Mac several times and it still happens.

    Later, I was told that my user account is set only having readonly. The scripts I created were written to memory. Thus, the Mac will eventlually ran out of memory and eggplant throws the NSmalloc Execption.

    If that is the case, why Eppplant software displays an error message?
    Instead, the capture images disappear from the Window and throw an exception. Is this an Eggplant software bug?

    Thanks,

    Shawn
  • EggplantMattEggplantMatt ForumAdmin admin
    This is pretty difficult to diagnose remotely. I've never encountered a read-only user account before. I'm pretty sure that Eggplant would complain if it couldn't save your scripts; it would only hold them in memory until you tried to save them. And there's no way that holding a script in memory caused Eggplant to run out of memory -- a really big script is only going to be a couple of MB.

    Did you run the dwrite to disable the thumbnail generation? Did that fix the problem?

    If you're still having the problem, please describe exactly what happens -- I'm not sure I understand the issue.
  • I encountered an NS Malloc exception error while trying to re-record an image. Attached is an exception report for your review.

    Thank you,
  • EggplantMattEggplantMatt ForumAdmin admin
    I think this is caused by Apple bug that causes the WindowServer process to leak a little memory every time a window is created. The only solution is to make sure that you either log out all users on the machine (which causes the WindowServer process to restart) or restart the machine. We recommend that you try to plan a restart of the machine weekly -- that should be often enough to prevent this particular problem for a system getting "average" use. You can check the status of the windowserver by opening a Terminal window and running the command:

    ps auxww | grep windowserver

    Look at the 5th value; if it's at or near 3.5 GB, then you need to either log everyone out or just restart the machine. There is a hard limit of 4GB/process. When the process gets into the 3+ GB range, it becomes more likely that it will be unable to allocate additional memory when it needs to.

    We know that Apple is aware of this problem (they requested logs from us) and that a side effect of it has affected Pixar, so we're hopeful that they will release a fix before too long, if not in a 10.5.x release, then hopefully in Snow Leopard.
Sign In or Register to comment.