Eggplant for Windows, UI updates

I am currently evaluating the Eggplant for Windows version. We are already using the Eggplant for Apple, but our company has a lot more Windows machines available, so using the Eggplant for Windows seems like a reasonable switch.

1) The Windows UI feels and looks like an early look UI and not a polished version. Is there any plan to put more polish on the Windows UI in the near future?

2) I am looking at trying to take a large number of Scripts and Images already captured on the Apple and using them on the Windows version. I have not yet been successful with this and I was wondering if there was any plans for an export / import feature to move scripts and images from one platform to another.

Comments

  • EggplantMattEggplantMatt ForumAdmin admin
    We do intend to keep refining the interface on the Windows product. You should just be able to copy your existing suites onto Windows -- all of the file formats are platform independent.
  • WmBellWmBell Member
    I have copied the entire suite from my Mac Mini and placed it on an external USB drive. I then copy the suite to my Windows XP machine in the same location (My Documents) that Eggplant puts the suite folders. When I open any of the scripts, there is nothing but unreadable characters in the script.

    Still looking for answers.
  • JonathanOSXJonathanOSX ForumAdmin admin
    This typically works flawlessly - scripts can be read by any version of Eggplant.

    Please feel free to send one of the scripts to our support address, perhaps that will help us determine what is wrong with the script.
  • WmBellWmBell Member
    Okay, I have found the reason I was having an error with scripts moved from Mac to Windows.

    1) When I open the Suite, I don't get a window with tabs (Scripts, Images, Results...), so I was just doing a File | Open Script.
    2) The file structure of scripts contains 2 copies of every script. The first half of the script names start with ._ followed by the script name. The second half of the list is just the script name.

    If you attempt to use the first and most obvious choices ._ you get an unusable script. If you scroll to the ones without the ._ you get your correct script.

    I was moving a suite containing a large number of scripts, so the ._ script were the only ones visible until I scrolled down several pages.

    Thanks for all the feedback Matt and Jonathan.
  • EggplantMattEggplantMatt ForumAdmin admin
    If you are getting a Suite window without tabs, I'm wondering if you are using the "Windows Classic" theme on the machine on which you are running eggPlant. We don't currently support the use of that theme. It's not a true theme in the sense of other XP themes; it's an instruction to the system to use older Windows drawing routines to display the UI. The libraries on which the Windows version of eggPlant rely are not able to access the UI elements produced by Windows in that scenario. Switching to the standard XP theme will provide a better user experience.
Sign In or Register to comment.