the code what makes eggPlant crash

Hallo,

I am testing the stability of eggPlant and the following code causes crash after some ~20-40 iterations.
put 0 into c
repeat while true
	put c + 1 into c
	SwitchConnection "UAT"
	Log "restart: "&c
end repeat

to SwitchConnection param
		Disconnect	
		Log "Connecting to "&param
		Connect(serverID:param,Visible:Yes)
		Log "Connected to "&param
		put param into global desktop
end SwitchConnection

I tested it on both Mac OS X and win32. Crash happened on both platforms. Is there anybody who faced similar error?

Comments

  • JonathanOSXJonathanOSX ForumAdmin admin
    What version number of eggPlant are you using?

    Also, please post or send the crash report from the Mac platform.
  • The version is v10.23 (1943)
    Unfortunatelly ~/Library/Logs/CrashReporter is empty :(

    If I start eggPlant from a terminal this is what I found ater it crashes:
    Trapped Signal 10 -- Attempting To Terminate
  • JonathanOSXJonathanOSX ForumAdmin admin
    Ran your script for 150 iterations here without issue. What is the VNC server/SUT that you are connecting to? Are you connected to any other servers at the time of the script run?
  • There is no opened connection in parallel.

    Machine:
    "Linux host 2.6.16.54-0.2.10-bigsmp #1 SMP i686 i686 i386"

    Xvnc version:
    "Xvnc version XF4VNC-4.4.0.0"

    Xvnc server parameters:
    "-geometry 1024x768 -depth 24 -rfbwait 120000 -rfbport 5901 -fp /usr/X11R6/lib/X11/fonts/misc:unscaled,/usr/X11R6/lib/X11/fonts/local,/usr/X11R6/lib/X11/fonts/75dpi:unscaled,/usr/X11R6/lib/X11/fonts/100dpi:unscaled,/usr/X11R6/lib/X11/fonts/Type1,/usr/X11R6/lib/X11/fonts/URW,/usr/X11R6/lib/X11/fonts/Speedo,/usr/X11R6/lib/X11/fonts/truetype,/usr/X11R6/lib/X11/fonts/uni,/usr/X11R6/lib/X11/fonts/CID"
Sign In or Register to comment.