Video Recording

I am attempting to get video recording working, but right now I get a video that is fairly large (350mb for 2 minutes) that is a blank black screen with my cursor moving around the screen.

In an attempt to figure out the problem I encountered this anomaly.

Put GetOption()
(forceScreenRefresh:"false", imageSearchCount:"7", imageSearchDelay:"0.3", keyDownDelay:"0.001", mouseClickDelay:"0.02", mouseDoubleClickDelay:"0.01", mouseDragSpeed:"10", mouseMoveDelay:"0.01", mouseMoveMode:"0", mouseMoveSpeed:"0", mouseRepositionSpeed:"0", nextKeyDelay:"0.01", preciseImageTolerance:"1", remoteWorkInterval:"0.7", sendShiftForCaps:"true", shouldRepositionMouse:"true", standardImageTolerance:"45")
result: Invalid Parameter, no option named "FullScreenFailsafe"

Have I done something that caused the invalid parameter, and if so how would I fix it?

Comments

  • EggplantMattEggplantMatt ForumAdmin admin
    Open the movie in Quicktime Player, go to the File menu, select "Save for Web?", and select "Computer" for the format. This will create a movie that will play on the 10.6 Mac. If you want to, you can even turn around and save that movie back to Quicktime format.

    What version of eggPlant are you running? The current release for the Mac is 10.23 and I think the issue with the invalid parameter has been fixed (it doesn't appear when I run that command).
  • When selecting Eggplant | About Eggplant, it lists Eggplant Version 10.2 (1763).


    Thanks for the tip on the videos. It worked fine, and now I now to update my OS. I am currently running Mac OS X 10.6.6.
  • EggplantMattEggplantMatt ForumAdmin admin
    You should definitely download and install version 10.23. There have been a number of bug fixes made since version 10.2.
  • I have downloaded the Version 10.23 from the downloads page, but it will not install over the top of the existing Eggplant software. Is there a patch file we can download, or an instruction for upgrading your eggplant software?
  • EggplantMattEggplantMatt ForumAdmin admin
    The new executable should just copy over the old one. You should make sure it's not running when you try to do it. There's no patch and the only instructions are to drag the new one to the Applications folder. Deleting the old version is optional, but might help if you run into a permissions problem.
Sign In or Register to comment.