Cannot use sendmail

Hi,

I am trying to send mail using sendmail. I am not successful and do not understand how to use it. Always seeing unable to authenticate error. My company however uses exchange server. How do I use a smtp account for this? Can we use any regular yahoo or gmail account for the purpose.

Thanks,
Vasavi

Comments

  • I couldn't get the free email services, including gmail, working with sendmail in Eggplant, so I pay a small amount a month for web hosting and email that works with Eggplant (plus I get a web server, database server, ssh, sftp and webdav that I can use for testing).
  • Found the solution. It works for me when I use it without any authentication. Problem solved for now.
  • after gone throught the post, i felt that you have experienced the same issue. could you please update me about the fix. there might be some sort of setting need to be done?
    I have tried by selecting the Mail preferencesAuthentication None/Plain.
    but getting the same exception.
    how do i add port in sendmail syntax?

    thanks,
    Sunflower
  • SenseTalkDougSenseTalkDoug ForumAdmin admin
    The latest release of eggPlant (v 11.3) includes a new email engine which does a much better job of sending email, particularly with regard to authentication and encryption issues. Please download the latest version and see the release notes for more details.

    To set a custom SMTP port to use for email, you can either specify it in the Mail pane of the Preferences panel, or include an SMTP_PORT: property in the property list passed to the SendMail command:
    SendMail (to:recipient, from:sender, body:myMessage, SMTP_PORT:8825)
    
  • Thanks Doug,

    I have eggplant V11.10 for Linux. I also verified by selecting the Mail Authentication as 'None' in Info->Preferences-> Mail pane, but i dont find any for SMTP_PORT field there.

    here is my blue print of script:

    RunWithResults "pricaticeTwo" --practiceTwo is another script
    Put the result into OutCome
    If the status of OutCome is not "SUCCESS" then
    put OutCome Logfile into screenError
    replace "Logfile.txt" with "Screen_Error.tiff" in screenError
    sendmail(to: "[email protected]", \
    form: "[email protected]", \
    Subject: title, \
    body: "test script for send mail", \
    smtp_host: "hostname.abc.com", \
    smtp_type: "None", \
    smtp_port: 8825, \
    attachment: (screenError, OutComes Logfile))
    else
    put "Every thing is OK"
    sendmail(to: "[email protected]", \
    form: "[email protected]", \
    Subject: title, \
    body: "test script for send mail SUCCESS", \
    smtp_host: "hostname.abc.com", \
    smtp_type: "None", \
    smtp_port: 8825)
    end if

    Getting the same error 'EDMailAgentException Authentication Failed' after executing the above code.

    please update me if any thing wrong in the above code.

    thanks,
    Sunflower
  • SenseTalkDougSenseTalkDoug ForumAdmin admin
    I strongly recommend upgrading to eggPlant v11.3, which includes a major overhaul of the SendMail functionality.

    Otherwise, your script generally looks fine at a glance, except for what appear to be some spelling errors and typos (e.g. be sure to use 'from' not 'form' in your actual script).
  • I am really sorry to not replying, as you have advised i have upgraded the eggplant to v11.3, then i configured the mail server details in Mail pane., then worked perfectly. thanks a lot.
Sign In or Register to comment.