Mac OS-X Auto completion

I am having a problem on Mac OS-X 10.3.9 with auto completion.

I have script which does the following:

Step 1: Opens Test_File with TextEdit
Step 2: Selects File/Save As
Step 3: Runs "Type Text "~/Desktop/05_13_05-08_58_11/Filename"
The "05_13_05-08_58_11" is a folder created with date and time, so that we can save the output files in different folders on the Desktop.

The problem I am having is with the Auto completion in the Finder, as you run the Type Text command the window trys to fill the line with the correct path name firstly of "Desktop" and then "Date-Time".

So intermittently we can have a Path name typed something like:
"~/Desktop/ktop/05_13_05-08_58_11/Filename"
or
"~/Desktop/05_13_05-08_58_11/08_58_11/Filename"

I have tried changing the Keyboard timing and also tried adding a wait command neither work.

How can I get around this problem?

Regards
Brick
:)

Comments

  • EggplantMattEggplantMatt ForumAdmin admin
    Brick:

    I'm going to have to play around with this some. I'm surprised that the typing is behaving this way -- I would expect it to override the autocompletion. Hmmm... are you using more than one TypeText command? Where did you try putting the Wait command and how did you adjust the typing speed?

    Sorry I don't have a definitive answer for you right now.

    Matt
  • BrickBrick Member
    Matt,

    I use a number of TypeText commands similar to:
    TypeText "~"
    wait 1
    TypeText "/Desktop/"
    --wait 1 Tried and removed
    TypeText date --Variable with a reformated date in
    --wait 1 Tried and removed
    TypeText "-"
    --wait 1 Tried and removed
    TypeText "time" --Variable with a reformated time in
    wait 1 Tried and removed
    TypeText "/"
    --wait 1 Tried and removed
    TypeText fileName --Variable with a file name in

    I tried adjusting the type speed in the :
    Eggplant/Preferences
    Run Options
    Keyboard
    key-Down Delay:

    Thanks
    Brick
  • EggplantMattEggplantMatt ForumAdmin admin
    Brick:

    Have you tried doing this as a single TypeText command?
    TypeText "~/Desktop/" &  date &  "-" & time & "/" &  fileName
    
    I would expect that to work a little more reliably, although I don't understand why you're seeing the behavior that you are. The autocompletion suggestion should be displayed highlighted and the typing should replace it. Did you adjust the typing speed up or down? What value did you use?

    Matt
  • BrickBrick Member
    Thanks EggplantMatt,

    That seems to work better, will need to do more testing later.

    Brick
    :)
Sign In or Register to comment.