Lion and Vine Server

Some testing with Lion reveals that Vine Server isn't happy. I would just like to know if there's any plans to update Vine Server for Lion.


  • yes

    Now that the GM is available, do you think you'll ship on or before the Lion release date?
  • I had been using TestPlant on Mac using Vine Server on a second user profile for a while now. I just upgraded to LION and now the Vine Server reports "Network not connected to allow connections to this IP.", Internal.

    At first I thought it's the version so I upgraded to Vine Server 3.12 and it's the same thing. My network has not changed at all.

    Does anyone have Vine Server working on Lion at all? Or is it just me?

    Without it working, I cannot use TestPlant actually... Am I missing a later version of V.Svr or something?
  • EggplantMattEggplantMatt ForumAdmin admin
    Lion hasn't been officially released yet. Expect that any issues with Vine will be addressed within a short time of its actual release.
  • maconamacona Member
    Yeah, its broken pretty good like. When I first installed Lion Server I got usereventagent hitting 90% cpu. Had to look at the log and found Vine was not happy. Tried to launch the Vine app and it crashes immediately. Had to go into the system to yank the files that made it start at boot to stop it.
  • You guys probably see the same thing, but just in case, here's the message from the "report" button when trying to open vine server
    Process:         Vine Server [10673]
    Path:            /Users/USER/Desktop/Vine Server
    Identifier:      com.redstonesoftware.VineServer
    Version:         3.0 (1016)
    Code Type:       X86 (Native)
    Parent Process:  launchd [131]
    Date/Time:       2011-07-22 01:04:52.124 -0500
    OS Version:      Mac OS X 10.7 (11A511)
    Report Version:  9
    Interval Since Last Report:          101663 sec
    Crashes Since Last Report:           7
    Per-App Interval Since Last Report:  16 sec
    Per-App Crashes Since Last Report:   5
    Anonymous UUID:                      A1222F17-A617-4D90-B34F-3E3AEE72E423
    Crashed Thread:  0  Dispatch queue:
    Exception Type:  EXC_BREAKPOINT (SIGTRAP)
    Exception Codes: 0x0000000000000002, 0x0000000000000000
    Application Specific Information:
    objc[10673]: garbage collection is OFF
    *** Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: '-[__NSArrayI removeObject:]: unrecognized selector sent to instance 0x440260'
    *** Call stack at first throw:
    	0   CoreFoundation                      0x929c4e77 __raiseError + 231
    	1   libobjc.A.dylib                     0x93bc7149 objc_exception_throw + 155
    	2   CoreFoundation                      0x929c8480 -[NSObject doesNotRecognizeSelector:] + 256
    	3   CoreFoundation                      0x929178a9 ___forwarding___ + 457
    	4   CoreFoundation                      0x92917672 _CF_forwarding_prep_0 + 50
    	5   Vine Server                         0x000091af Vine Server + 33199
    	6   Vine Server                         0x00009b8b Vine Server + 35723
    	7   CoreFoundation                      0x92922daa -[NSObject performSelector:] + 58
    	8   CoreFoundation                      0x92922d27 -[NSSet makeObjectsPerformSelector:] + 247
    	9   AppKit                              0x91dc08d3 -[NSIBObjectData nibInstantiateWithOwner:topLevelObjects:] + 1315
    	10  AppKit                              0x91db6679 loadNib + 380
    	11  AppKit                              0x91db5cbe +[NSBundle(NSNibLoading) _loadNibFile:nameTable:withZone:ownerBundle:] + 841
    	12  AppKit                              0x91db596a +[NSBundle(NSNibLoading) loadNibFile:externalNameTable:withZone:] + 154
    	13  AppKit                              0x91db589e +[NSBundle(NSNibLoading) loadNibNamed:owner:] + 418
    	14  AppKit                              0x9203c8f3 NSApplicationMain + 445
    	15  Vine Server                         0x000088d6 Vine Server + 30934
    	16  Vine Server                         0x000087fd Vine Server + 30717
    Thread 0 Crashed:: Dispatch queue:
    0      	0x929c4d67 ___TERMINATING_DUE_TO_UNCAUGHT_EXCEPTION___ + 7
    1   libobjc.A.dylib               	0x93bc7149 objc_exception_throw + 155
    2      	0x929c8480 -[NSObject doesNotRecognizeSelector:] + 256
    3      	0x929178a9 ___forwarding___ + 457
    4      	0x92917672 _CF_forwarding_prep_0 + 50
    5   com.redstonesoftware.VineServer	0x000091af 0x1000 + 33199
    6   com.redstonesoftware.VineServer	0x00009b8b 0x1000 + 35723
    7      	0x92922daa -[NSObject performSelector:] + 58
    8      	0x92922d27 -[NSSet makeObjectsPerformSelector:] + 247
    9              	0x91dc08d3 -[NSIBObjectData nibInstantiateWithOwner:topLevelObjects:] + 1315
    10              	0x91db6679 loadNib + 380
    11              	0x91db5cbe +[NSBundle(NSNibLoading) _loadNibFile:nameTable:withZone:ownerBundle:] + 841
    12              	0x91db596a +[NSBundle(NSNibLoading) loadNibFile:externalNameTable:withZone:] + 154
    13              	0x91db589e +[NSBundle(NSNibLoading) loadNibNamed:owner:] + 418
    14              	0x9203c8f3 NSApplicationMain + 445
    15  com.redstonesoftware.VineServer	0x000088d6 0x1000 + 30934
    16  com.redstonesoftware.VineServer	0x000087fd 0x1000 + 30717
    Thread 1:: Dispatch queue:
    0   libsystem_kernel.dylib        	0x961cd90a kevent + 10
    1   libdispatch.dylib             	0x917a3ccc _dispatch_mgr_invoke + 969
    2   libdispatch.dylib             	0x917a271b _dispatch_mgr_thread + 53
    Thread 2:
    0   libsystem_kernel.dylib        	0x961cd02e __workq_kernreturn + 10
    1   libsystem_c.dylib             	0x9324cccf _pthread_wqthread + 773
    2   libsystem_c.dylib             	0x9324e6fe start_wqthread + 30
    Thread 3:
    0   libsystem_kernel.dylib        	0x961cd02e __workq_kernreturn + 10
    1   libsystem_c.dylib             	0x9324cccf _pthread_wqthread + 773
    2   libsystem_c.dylib             	0x9324e6fe start_wqthread + 30
    Thread 0 crashed with X86 Thread State (32-bit):
      eax: 0x00000001  ebx: 0x00445a60  ecx: 0x00000001  edx: 0x00000000
      edi: 0x00445ac0  esi: 0x93bc70bf  ebp: 0xbffff088  esp: 0xbffff080
       ss: 0x00000023  efl: 0x00000282  eip: 0x929c4d67   cs: 0x0000001b
       ds: 0x00000023   es: 0x00000023   fs: 0x00000000   gs: 0x0000000f
      cr2: 0x0dc83000
  • Dear Matt Hicks,

    Vine Server is not working on Lion and when it run, it print "CGDisplayBaseAddress is obsolete and returning NULL for display 0x1b6a6a80" in consol

    Please let me know when do you have plan to release vine server for lion
  • JonathanOSXJonathanOSX ForumAdmin admin
    We do plan to update Vine Server to work with Lion in the future -- but much of the core of Vine Server will need to be modified because the API's that are currently in use are deprecated in LION.

    At this time we recommend using Apple Remote Desktop configured to allow VNC access.
  • maconamacona Member
    Unfortunately, the new built in VNC server works with very few clients, and almost none PC.
  • zankzank Member
    The Inbuilt VNC server does not work well, a default Vine Server that was provided seems to be the only accurate solution, please keep us posted on the progress of the status of Vine Server, we would love to continue working with this rather than looking for any alternates.
  • rogkrogk Member
    edited August 2011
    I can only get RealVNC to work. However, the built-in server appears to use ZRLE encoding, which is very slow. Looking forward to a Lion-supported release soon!

    Edit: Ergh... Scratch that. I can only get to the login screen/password prompt with either (ZRLE/Tight) encoding. Seems the problem is with Lion's authentication (see here and here).
  • We do plan to update Vine Server to work with Lion in the future -- but much of the core of Vine Server will need to be modified because the API's that are currently in use are deprecated in LION.

    At this time we recommend using Apple Remote Desktop configured to allow VNC access.

    I think "deprecated" isn't exactly right. CGDisplayBaseAddress is "obsoleted" in Lion (meaning completely disabled), but was deprecated as of the release of Snow Leopard , so it should come as no surprise since August 28, 2009 was nearly two years ago!

    That said, I do understand what a big deal it is to switch to the OpenGL alternative, GL_APPLE_client_storage and the amount of testing and debugging that will require and I volunteer my services in testing builds and contributing to get Vine Server up and running on Lion - just contact me and I'll do what I can to assist.
  • Add me to the requests for Lion Support. Have held upgrading until most issues are resolved, and Vine Server seems to be the only app I have that will not work (from what I checked)

    Also - Is Vine Viewer working in Lion?

  • Adding to the "VNC coming with Apple Remote Desktop seems not work so well"-choir, does anyone also receive a yellow screen if using either Eggplant or Vine Viewer with Apple Remotes Desktop VNC? Is there a way to get rid of it?

    Looking forward to a compatible Vine Server solution 8)
  • EggplantMattEggplantMatt ForumAdmin admin
    Try changing the color depth on the connection from "Default" to "Millions" and see if that fixes it.
  • No updates yet for Lion for server? For Viewer?
  • EggplantMattEggplantMatt ForumAdmin admin
    Not yet. We'll announce it here when it's available. There's no definite timeline at this point.
  • I just tried the "Vine Server 4 Beta for Mac OS X 10.6 and 10.7 (Lion)" from the Downloads page, and it works great on my Lion Mac mini (2.3 Core i5), at least on the first connection [1].

    That's fantastic, thanks a lot guys!

    Do you have a donation page for Vine Server? I've been using it for ages and I'd like to express my gratitude.

    [1] Reconnecting a VNC client has never been stable for me, not even with Vine Server 3.12. Now with V4 on Lion, the screen sometimes goes black on the client, but the mouse pointer still moves. Sometimes, the Vine Server app also crashes.

    But since I'm logged in via SSH, two short commands resolve the situation:
    osascript -e "tell app \"Vine Server\" to quit"
    osascript -e "tell app \"Vine Server\" to launch"
  • EggplantMattEggplantMatt ForumAdmin admin
    So you're saying that the screen of the machine that you're actually logged into goes black? Or just that the VNC viewer window goes black? If it's the latter, which VNC viewer are you using?

    I can't recall ever hearing a report of this behavior before. There are a couple of places you could look to find more information on what is happening: One is in the Console (on the machine running Vine) and look for messages related to the display (it sounds more likely that these would be coming from the system than from Vine). In particular, you might see what pops up in the console after you issue the quit and launch commands. The second thing is if there is a crash, there should be a crash report generated in ~/Library/Logs/CrashReporter/ (~/Library/ is now a hidden folder under Lion, but you can use Go To Folder and type the path). If you find a crash report there for Vine, post it here and we'll take a look at it.

    We don't have a donation page for Vine, but if you're ever in the market for a nice VNC Viewer for the Mac, you could always buy copy of Vine Viewer.

    Thanks for your feedback.
Sign In or Register to comment.