Video Stream

I need to verify that the streaming video loaded.

The mobile phone is on the page where the video stream is, however the VNC viewer is displaying a black screen everytime I enter a video stream. It does not do this on the other pages. As a result, when I capture the screen after 30 secs, I get a black screen for a tiff. Is there a way to resolve this issue?

Comments

  • EggplantMattEggplantMatt ForumAdmin admin
    Unfortunately there's no way to access the video if that's what you're seeing. The Veency server can't access the OpenGL layer that the video stream is probably using for the display. We've investigated having the Veency source modified to gain access to this layer of the OS and it just wasn't possible.
  • Blackscreen appears for CaptureScreen on Droid VNC Server. Eggplant's VNC Viewer captures the video, however when you CaptureScreen, it is a black tiff image as well.
  • By the way my original question was pertaining to iPhone's Veency server. I tried with the Android, and its Droid VNC Server is also capturing screenshots as a black screen.
  • JonathanOSXJonathanOSX ForumAdmin admin
    Kathryn:

    For places where it shows up on the Remote Window if you are capturing only a portion of the screen you may be running into an eggPlant bug that is fixed for the v11 release.

    You might try to capture the entire screen and see if that helps your problem for now.
  • Jonathan: I did not capture a portion, I captured the entire screen. The black screen only occurs when I capture the screen that has Video Stream. Please let me know if there is a workaround. Ensuring that the video launched is what I need to automate for, live video streams is our application's product.
  • JonathanOSXJonathanOSX ForumAdmin admin
    At this point I'm not sure if you are seeing some new issue or what.

    If you can please send both a screenshot of your workstation and the image file that Eggplant created to [email protected]
  • Jonathan:

    For Android it is capturing the screen of the video afterall. I retested it and so long as I see a video on the viewer, and I CaptureScreen, then I see the screenshot of the video. I do not see a black screen.

    For the iPhone that uses Veency - everytime I go to the page where it loads a live video stream, the viewer turns all black. So when I capture the screen, I see a black image. I will retest it again and send you a screenshot.
Sign In or Register to comment.