InitialSuites not working

This is the code using OpenSuite, which works fine, I am opening a suite from another suite
OpenSuite("prpc_1")
sensetalk_demo #Calling a script in the suite included by calling OpenSuite
put "done"
prpc_login.sayHi #Calling a method in the script of the opened suite

When I replace the OpenSuite with set the InitialSuites to ..., it is failing

set the initialSuites to "prpc_1"
sensetalk_demo #Calling a script in the suite included by calling OpenSuite
put "done"
prpc_login.sayHi #Calling a method in the script of the opened suite

2-Sep-11 23:59:05 START Running Selection from test.script
2-Sep-11 23:59:05 set INITIALSUITES = prpc_1
Selection Failed in 0:00:00 STUnknownMessage ERROR: No Such Command: 'sensetalk_demo'

Do I have to any thing different if I use initialSuites instead of OpenSuite?

I am trying to add another suite in the script instead of adding as a helper.

Using Eggplant 11 on Windows 7, for this script there is no VNC involved.

Thanks
Jag

Comments

  • EggplantMattEggplantMatt ForumAdmin admin
    "the initialSuites" is a list, even if there is only one. So your syntax needs to be
    set the initialSuites to ("prpc_1")
    
    If you have more than one, then it would be:
    set the initialSuites to ("prpc_1",  "prpc_2")
    
  • No luck Matt, I tried both ways taking it from your previous replies, for now we may use OpenSuite and OpenSuites to do the same. I can provide more information if you want
    my new script looks like this

    set the initialSuites to ("prpc_1" )
    #OpenSuite("prpc_1")
    put "**************************"
    sensetalk_demo #Calling a script in the suite included by calling OpenSuite
    put "**************************"
    prpc_login.sayHi #Calling a method in the script of the opened suite
    Thanks
    Jag
  • EggplantMattEggplantMatt ForumAdmin admin
    Sorry. The additional problem is that you need to specify the .suite extension:
    set the initialSuites to ("prpc_1.suite")
    
  • OK, Matt, I think I found the problem with initialsuites, unlike OpenSuite, looks like for InitiaSuites we need a fully qualified path like "c:\Automation\prpc_1.suite" and it worked.

    I tried referring like "..\..\prpc_1.suite" so that we do not have to rely on hard coded path, it did not work. Any thoughts?
    Thank you!

    Jag
  • Is there a way to use the relative location of suite for initialSuites just like OpenSuite? OpenSuite("(“/Common/Example Suite ") works, what is the equivalent for set the initialSuites? when I tried
    set the initialSuites to (“/Common/Example Suite.suite "), it is looking at the Documents folder, is it a bug?

    Thanks
    jag
  • EggplantMattEggplantMatt ForumAdmin admin
    When setting "the initialSuites", the path is relative to the Default Suite Directory. If all of your suites are stored in the Default Suite Directory on every machine on which you run eggPlant, then all you need to specify is the name of the suite (with the .suite extension). That of course assumes that every machine on which you run eggPlant has all of the suites that you refer to. Note that the suite in which you are setting "the initialsuites" does not itself need to be in the Default Suite Directory.
Sign In or Register to comment.