Windows 7: Cursor shoots to bottom right

My test forces the mouse to the bottom right of the screen, over the "Show Desktop" button, causing it to display the background with diagonal stripes over it. How do I prevent this from happening?

Comments

  • Saltsman,

    This problem occurs when eggPlant cannot find an image that it is looking for. When it does not find the image on the screen, it moves the cursor out of the way in case it was in front of the image. The default in eggPlant is for it to move the mouse to the bottom right corner of the screen. On Windows 7 specifically this can be a problem because of the "Show Desktop" feature.
    There are a few things you can do. For one, you could disable the "Show Desktop" feature on the SUT by right clicking on the start bar at the bottom of your screen and disabling the feature.
    Another option is to write into your script a command to disable the setting in eggPlant that moves the mouse to the corner. Most of the time the mouse is not really a problem, and if you disable this setting it is unlikely to cause problems. This can be done with the ShouldRepositionMouse property. In order to turn the default setting off, you would need to add a line in your script that read:
    Set the ShouldRepositionMouse to false
    
    This would turn that setting off in eggPlant from that point on only and during that script only.
    Your third option is to disable the setting permanently by going to the Preferences panel in eggPlant and then clicking Run Options (EggPlant > Preferences > Run Options). You will want to disable the Should Reposition Mouse selection in the bottom half of the window.

    -Elizabeth
  • Thanks Elizabeth, that fixed it for me.
Sign In or Register to comment.