Image recognition failing more on newer version of eggplant.

Hi all,

We just recently have updated to the newest eggplant 11.22. In doing so we are noticing a lot of scripts failing due to image recognition, whereas on the other version of eggplant we were pretty close to 100% passing for all scripts. Now scripts are failing left and right all due to image recognition. Any ideas?

Is there something we need to adjust?

Comments

  • EggplantMattEggplantMatt ForumAdmin admin
    The latest release is 11.3 (just released last Friday). Nothing would have changed with image recognition in that release or any previous release going back a long ways. You should send an email to support with samples of the failing images, screenshots, and the script code. Did you change SUTs?
  • nope, same SUT's, same code...just different version of eggplant. images were working fine before upgrading...scripts were ran nightly for months with no issues. we upgraded and well, image failures everywhere.
  • EggplantMattEggplantMatt ForumAdmin admin
    When the script fails, does it look like the image that it failed to find is displayed in the screenError.png file that is automatically captured when an image search fails? If not, then this is a timing issue.

    Other than that I can't even hazard a guess without seeing the sample images and other information that I requested previously.
  • EggplantMattEggplantMatt ForumAdmin admin
    Would still like to help you resolve whatever issues you are seeing, but I haven't seen any of the other information that was requested.
  • Was the image recognition sped up in the newer versions? Cause what I'm trying to say Matt is we run these scripts "every day" for like a year now. Everyday it is a successful pass. We upgrade and now those scripts that have been working for over a year are now failing. If this is a timing issue, it's not something to do with our scripts, unless we have to change the timing now due to some change in the eggplant software.
  • EggplantMattEggplantMatt ForumAdmin admin
    No, nothing was changed related to image searching or timing. And I can't offer any suggestions without more information. I need the captured images and the screen_error images. Having before and after result files would also be useful. But please email those to support -- do not post them here.
Sign In or Register to comment.