TypeText not working as expected on Ubuntu 13.04

I am trying to port my scripts from Windows( XP, 7, 8 ) to Mac(10.6, 10.8 ) thence to Linux(Ubuntu 13.04).

So far the using --TypeText controlkey(commanddKey),"t"-- as a hot key, will work on every OS except Ubuntu 13.04. To clarify, if I use the keyboard attached to the SUT, the hot key combination works as it should. If I try the same command using eggPlant's TypeText command it does not seem to work.

Does anyone know what I am doing wrong and do you have a solution?

Comments

  • Hi Scott, I have exactly the same issue, and I was wondering if I made a mistake somewhere. I am using Ubuntu 13.04 too.

    Please help Eggplant Team..!!!
  • JonathanOSXJonathanOSX ForumAdmin admin
    That's very strange. Just to be clear you are controlling a Ubuntu 13.04 SUT from eggPlant (which platform is eggPlant running).
    This command should always send the same thing:
    TypeText ControlKey, "t"
    
    I assume you are using the built in VNC server on Ubuntu. Is it running in a VM that might be doing it's own remapping of Modifier Keys?
  • My testing machine is running Windows XP sp3 and communicating with the SUT over RealVNC 5. The SUT is running VirtualBox 4.2.14r86644 on Windows 7 Enterprise sp1.

    I have set the 'Host Key' in VirtualBox to Alt so that I can test our hot keys which typically use the control key as part of the combination.

    It is possible that VirtualBox is hampering my efforts but I'm not sure how or why this would affect the Ubuntu image only?

    When I use the HotKey combination on the keyboard attached to the SUT, our application responds as I would expect.

    Sending the hotkey combination over a VNC connection , without eggPlant, causes the application to work as expected in Ubuntu. The only way it does not work is when I add eggPlant to the equation.

    I have no idea what this means, I can only tell you what I am seeing. Is there a setting that might affect this?
  • JonathanOSXJonathanOSX ForumAdmin admin
    Can you try it with the built in "Screen Sharing" (which is a VNC server) to see if that works any better?
    [/quote]
  • Hi JonathanOSX,

    I am also getting same problem.
    While entering text in address bar of Internet explorer typing correct text when hit on enter the text is getting changed. Like example below
    TypeText https://test.company.com/.../Release_PAT_1.3.4/WEBs/Obfuscated/PC/
    
    but eggplant giving after hit on enter button
    https://test.company.com/.../Release_PAT_1.3.4/WEBs/Obfuscated%20/PC/
    
    because of this I am not able to continue with my script.

    Can you please help me !
  • JonathanOSXJonathanOSX ForumAdmin admin
    This isn't a TypeText problem.

    I think you have a space in your typetext command (after Obfuscated).

    When you hit return the browser is turning that into the url-safe version of the space character, %20.
  • Jonathan,

    I tried to connect directly to the Ubuntu 13.04 VirtualBox Image using VNC and eggPlant but neither of those attempts were successful. I received a connection refused error both times. Not sure what the problem is but it is vexing.

    Perhaps I do not understand what you are suggesting that I try. "Screen Sharing" is specific to MAC as far as I know and have been told. Perhaps, if you would be so kind as to provide a detailed set of instructions so that I can get this sorted out.

    Thank you
Sign In or Register to comment.