eggPlant on Linux/RedHat

Hello,

I was wondering whether anyone has installed eggPlant Functional on Linux/RedHat? It doesn't seem to run well.

When entering the License Panel, the screens text disappear, and the text cannot be read after few clicks. Almost like eggPlant is crashing.

In addition, we are using Standalong/Node Lock license, and even if we manage to put the license in, it still complains this License Server key is not valid.

Any help would be appreciated.

Comments

  • EggplantMattEggplantMatt ForumAdmin admin
    You need to be more specific about what version of Linux you are installing on. The term "Linux" is fairly meaningless because there are so many variants and versions. RedHat obviously narrows it down, but there are still many versions available. If you launch eggPlant via the command line, are there any error messages?

    From the error message you've reported, it sounds like you are launching the Team License Server, not the eggPlant Functional application.
    the text cannot be read after few clicks.
    If you haven't licensed it, what are you clicking on?
  • Hi, and thanks for getting back to me. Sorry for not being clear, I'm a windows person, but here are the info you asked for:

    Version:
    Linux RHEL-BLD1 3.10.0-229.11.1.el7.x86_64 #1 SMP Wed Jul 22 12:06:11 EDT 2015 x86_64 x86_64 x86_64 GNU/Linux

    I am confused between eggPlant Functional and TLS. I ran the .rpm I was provided for our RedHat. I thought it's eggPlant Functional. So, what I am running is "efls" from command line, in order to put the License Key, however the text on dialog box keep disappearing after one or two clicks.
    I was thinking of reinstalling the .rpm.

    "the text cannot be read"...this is on the License Panel dialog, where you're inputting the License Key and Username. I cannot see what I am inputting because of the text disappearing.

    I wonder if I was provided the correct .rpm for our system.

    Somehow, I manage to somehow put the license, but it never accepts it and I get this license key is not valid.

    Then, finally, I type "eggplant" on command line, but get this:

    [[email protected] ~]# eggplant
    /usr/GNUstep/System/Tools/gpbs: /usr/GNUstep/System/Library/Libraries/libjpeg.so.62: no version information available (required by /usr/GNUstep/System/Library/Libraries/libgnustep-gui.so.0.23)
    /usr/GNUstep/System/Tools/gpbs: /usr/GNUstep/System/Library/Libraries/libjpeg.so.62: no version information available (required by /lib/libtiff.so.3)
  • I finally was able to punch in the License into the dialogs with many tries...

    It looks that it finally took it and eggPlant connection list is up.
    However, when adding and connecting to our SUT, we get error message "too many security failures".

    Both TEST and SUT are Linux machines with the above given versions.

    We are connecting fine from our Windows machine to our SUT machine, but from this TEST machine Linux based connecting to SUT, we get "too many security failures".

    Has anyone ran into this issue before?
  • EggplantMattEggplantMatt ForumAdmin admin
    This message comes from the VNC server. It generally indicates that several attempts to connect were made with bad passwords or an incorrect security setting. The server will temporarily blacklist the IP address of the offending machine. You usually need to either wait a while before trying again or restart the server to clear out the blacklist.
Sign In or Register to comment.