Screen lock kicks in even though there is continuous activity on SUT in RDP ( Windows)

pevspevs Member
edited April 2018 in Eggplant Functional

Seen plenty of questions asked and answered about how to deal with inactivity and screen locks however mine is the opposite.


Scenario ( Windows environment) :

In Eggplant Functional RDP to SUT and in Live Mode write / run a test on app.

Test running \ activity continuously occurring

Screen lock pops up. The eggplant connection is still active ! I have to log back in to continue.


However if I RDP to the SUT windows box  from my  local windows machine I get no such problem.  ( ie not from Eggplant Functional) .


Wondering if this is an Eggplant specific issue. ( don't know why though !)



Answers

  • kenandruskenandrus ForumAdmin, Member admin
    Hello pevs,
    I would recommend that you submit issues such as this one to [email protected]  One possibility is that another RDP session is highjacking your connection--typically only one RDP session at a time is possible on a SUT.  Also, just because the connection is active doesn't mean that it will keep the screen from locking.  There does need to be interaction with the SUT display within the configured timeout setting in order to prevent the security screen lock from diplaying.  You might turn off any energy-saving sleep settings in order to avoid that possibility.  We hope this helps, but please follow up with us at the support email noted above if it does not help.
Sign In or Register to comment.