Text Image Problems...

Hello everybody--

I have the following piece of code that works:
Click(text:"Title",Hotspot:(42,8)
I copy and paste this to a new line and change it to:
Click(text:"Composer",Hotspot:(42,8)
The text exists and is in the same text style as the text above it, however Eggplant can't find it.

I've also discovered that on Mac, the text image generation does not like text on buttons. I've yet to get it to click a button with text on it (i'm guessing it's because of the 3-d nature/shading of the buttons). I'm guessing I'm doing something wrong, but I'm not quite sure what.

Thanks for any suggestions.

Comments

  • You may want to compare your generated image with the actual image that is on the screen to determine if there are any differences between the two. The procedure for comparing images in Photoshop can be found here:

    http://www.redstonesoftware.com/phpBB2/viewtopic.php?t=180

    If you are trying to generate a text image for a target item with a slight pattern for the background you might want to experiment with a higher level of image tolerance.
    Click(text:"Composer",Hotspot:(42,8), tolerance:80)
    

    Try not to specify too high of a value for this property otherwise, you will end up with false-positive image matches.

    Designating a background color with a high level of tolerance however, may not always be enough for text images on patterned backgrounds. In these situations it is often better to capture the images manually as opposed to generating the image.

    Similarly, the text image generation feature was not designed for the pulsing nature of buttons. Pulsing buttons too, should be captured manually.
Sign In or Register to comment.