VNC problem with Windows Vista

Hi.

I tried connecting Eggplant to a Windows Vista 32 bit OS. But after the connection is open, the Live Screen window does not show the Vista UI. The live window shows blank.

Is it a problem with VNC running on Vista OS??? I'm using VNC Server for Win32 version 4.0

Comments

  • ToddTodd Member
    edited February 2007
    Are you able to get connections and SUT desktop displays established with other VNC Servers, say on WinXP or with OSX from the same system you are having problems displaying Vista?
  • JonathanOSXJonathanOSX ForumAdmin admin
    We recommend using RealVNC 4.1.2 for Windows, that version can be configured to run on Vista but requires a particular setup as described here:

    So in order to make VNC server on Windows Vista works properly, the workaround resolution (at least until the VNC developers to come out with proper fix or update to address the new security constraint in Windows Vista) is to run VNC server in user mode.
      *Ensure that you have the exceptions to allow incoming connections to winvnc4.exe or to port 5900 (or any other port number that you want to allocate to VNC server listening port), or simply turn off firewall. *VNC server is detected as potentially unwanted behaviour in integrated Windows Defender. Create a rule to ignore this warning. *If you want to newly or fresh install VNC server, do not install the VNC Service by not checking or selecting the ?Register VNC Server Service? option, or else you will have ?Not Accepting Connections? error even when trying to run the VNC Server in User Mode. *If you have already install VNC Service (register VNC Server as a service to start automatically when Windows Vista starts), unregister the VNC Service. *If you want to configure settings of VNC Server, right click on ?Configure VNC Server? menu item and select ?Run as? for administrative privileges so that the VNC configuration tool can access to the relevant parts of the registry. *Then start VNC Server in User Mode (may need to Run as Administrator too), and you will be able to connect, remote control and access to Windows Vista computer desktop from another computer properly. [/list:u] This information was originally posted here with some additional information:
    http://www.mydigitallife.info/2006/12/13/workaround-to-run-vnc-server-in-windows-vista/
  • PayalPayal Member
    Hi,

    We scripted using the text image method on Win XP Professional OS on a 32 bit machine. But while running the scripts on Win Vista OS, we found that the scripts failed as many text were not identified on it.

    The text images works in case of XP and 2003 Server, but is failing in case of Vista for the same display environment. Is this the expected behavior of Eggplant???

    Does the font support of Vista differs from that of XP & 2k3 OS???
    Is it not possible to use the same scripts of XP & 2k3 on Vista!!! Or required to script separately for Vista OS???
  • JonathanOSXJonathanOSX ForumAdmin admin
    Payal:

    Can you please post (or send to support) some specifics about which fonts you are using, possibly some screen shots of the text you are trying to match and the resultant TIG image.
  • Hi

    I have realvnc personal edition, v 4.2.8 running on a vista machine in user mode. I can connect to with via my pc using a realtvnc client.

    However on my mac running eggplant, version 3.3 (1085), I get an error saying No configured secuity type is supported by 3.3 viewer.

    ---
    If I use tightvnc on the vista machine, I can connect to it from my eggplant mac just fine, but as mentioned I don't have support for the windows key.

    Thanks!

    Sam
  • JonathanOSXJonathanOSX ForumAdmin admin
    For RealVNC 4 Personal Edition you will need to set your authentication to "No Auth" or the standard "VNC Password" style of authentication to be able to connect to it.
  • There is another solution instead if you don't want to have to disable UAC if you install eggplant to C:/ instead of into program files it bypasses the UAC and you don't have problems then. I found this out last week! :)
Sign In or Register to comment.