VNC with SSH has stopped working

jhunseljhunsel Member
I had successfully connected remotely to my home Mac using SSH, then using ChickenOfThe VNC to make the GUI connection. I was able to do this 3-4 times. Then I started having problems with the VNC portion out of nowhere.

I began checking the OSXVNC server settings at home. It said it wasn't running, but when I clicked the Start button, it said it was already running on 5901. That didn't seem right, so I installed the newer Vine Server to see if it would make a difference, which it did not. However, a recent check shows that it claims to be running on 5901.

I can use Terminal to SSH and can make the connection. However, it reports:
bind: Address already in use
channel_setup_fwd_listener: cannot listen to port: 5901
Could not request local forwarding.

It lets me move around with command line, but VNC will not make the connection.

I'm at a loss. I have not changed anything on my router from when it was working before. I have a static IP on the Mac and a DynDNS address. I'm running Mac OS 10.4.9. The client that I'm testing from is also Mac 10.4.9. CotVNC is version 2.0b2.

I don't know where to begin, so any help is appreciated. Thanks.

Comments

  • JonathanOSXJonathanOSX ForumAdmin admin
    All indications are that port 5901 is in use (by something). If you configured VNC to run as a System Server (under the Startup tab) then you might want to use the "Stop Server" button to clear that off.

    Then you can either reconfigure the Startup Server or just launch the GUI.
  • So stop the server and disable the startup item, then don't use the startup item again? How will that affect things on a reboot of the computer, such as a manual restart or an auto restart after a power failure (and I'm out of town)? Am I wrong about what that item does?

    -Jeff
  • JonathanOSXJonathanOSX ForumAdmin admin
    You have that correct about how the System Server works, sorry if I was unclear.

    What I'm suggesting is that you have one configred and running on port 5901 already. I'm not sure exactly why your SSH is failing but clearing it and putting a new System Server up with exactly the settings and password that you expect might help.
  • I stopped 5901 and restarted, but I have the same problem. I started a new one on 5902 and it's working again, so I'm happy there.

    So what happened on 5901 and how can I clear it? It doesn't appear that the options in Vine Server are making any difference for 5901.

    -Jeff
  • ToddTodd Member
    It would seem either 5901 is blocked, or is being used by another program. Possibly another system level Vine Server (or possibly another service/server) running on port 5901? Bring up Activity Monitor and select the administrator level processes display, and see if you have an instance of OSXvnc running. If so, kill it. Also unconfigure the setup so that OSXvnc will not run automatically as an admin level service. To do this, run Vine Server -> Startup -> Stop System Server.
  • Interestingly, I was going to connect remotely to view the Activity Monitor, but now when I try to SSH access is denied. I was able to do connect twice before I made my prior post.

    I was previously running OSXvnc on 5901, but now I'm running Vine Server on 5902 (after 5901 wouldn't work). I assume that you are not referring to the different versions of the software, but are using the two names interchageably for the same product.

    I will check the Activity Monitor later and will provide another update then.

    -Jeff
  • jhunseljhunsel Member
    OK. I checked the Activity Monitor and OSXvnc is running. Just to confirm, killing it will reset 5901 and 5902? Then I should be able to reconfigure 5901, and should do so as a Startup Item, not with Start/Stop Server?

    -Jeff
Sign In or Register to comment.