Copy/paste issue thru Vine Server

ngargngarg Member
Hello, I' using Vine Server to get data copied on Clipboard from my application using command - remoteClipboard() and data has been copied to Clipboard from application in following way:

Typecommand a,c
b. wait 2
c. log remoteClipboard()

Actual Result:
Junk character displayed before word typed..

More Ifo:
My application writed Plain as well Unicode data to system clipboard using Scarp manager routines...
Few observations:
1. remoteClipboard() API works fine if I don't write Unicode data and just writes Non Unicode data.
2. While writing Unicode data - BOM has been added in first two bytes which is 0xFEFF for representing UTF16 encoding.
3. remoteClipboard() adds standard 3 byte(0x95C7BC) in front of text.
4. When I modify BOM data -- these Junk bytes do have different values.

Can you please help whats wrong here? --
.

Comments

  • SenseTalkDougSenseTalkDoug ForumAdmin admin
    What OS and VNC server are you running on the SUT?
  • ngargngarg Member
    OS: MACOS X, 10.4.9
    Vine Server : version 2.2
  • ngargngarg Member
    Any update on this would be helpful ....
  • SenseTalkDougSenseTalkDoug ForumAdmin admin
    I've verified that there is a problem with clipboard transfers of Unicode characters beyond the ASCII range, and have been trying to find a useful workaround.

    I thought it might be possible to use the defaultStringEncoding property to force a conversion from whatever format it's in to get back the original (by writing the value to a file with one encoding and reading it with another), but I'm not sure that will be possible -- at least, I haven't yet found a combination that works.
Sign In or Register to comment.