typeCommand "H" does not work with iMAC SUT

Hi,
I have a problem with typeCommand on my new iMAC SUT:

typeCommand "H" (hide current acctive window)
or typeCommand "Q" (quit currently active application)
work perfectly fine with powerPC MAC OS 10.4.10 SUT.

Today I tried to run my scripts with the new SUT - iMAC with 10.4.10.
And on iMAC the above commands do not work - nothing happens when they are executed. I tried
typeText commandDown, "H", commandUp
it does not work either.

Is there some setting that I have to change on iMAC?
Thanks.

Comments

  • Eggplant -> Preferences -> Keyboard -> Send shift key down for capitals

    See if this helps for your situation.
  • JonathanOSXJonathanOSX ForumAdmin admin
    The TypeCommand command is insensitive to case so it should work just fine. The TypeText command however will press the shift key to get capital letters (by default) and so probably won't work.

    In terms of why TypeCommand "H" isn't working it might depend on your Application, some applications do not have that standard Command key setup (Adobe apps). Also, you can't hide the "last unhidden app".
  • --Eggplant -> Preferences -> Keyboard -> Send shift key down for capitals

    It was check marked

    --In terms of why TypeCommand "H" isn't working it might depend on your Application, some applications do not have that standard Command key setup (Adobe apps). Also, you can't hide the "last unhidden app".

    I was trying to hide Finder window with TypeCommand "H" and Finder has this key setup. Finder was not the "last unhidden app". I tried to hide it to bring focus to another opened window - Mac Terminal.
    And all of this works perfectly fine on my other SUT - powerPC MAC 10.4.10.
  • I tried other shortcut keys available in Fnder:
    typeCommand "A"
    instead of selecting all, it would highlight Applications folder

    typeComand "N"
    instead of opening a new Finder window, it would create a new folder


    typeCommand "I"
    instead of displaying info on a highlighted item, it would pop up a dialog box "Connect to disk"

    It looks like shortcuts do not work at all.
    Any help with this will be appreciated. My existing scripts use the shortcuts a lot, and they all work on powerPC MAC OS 10.4.10 SUT.
    Thanks,
    Anna.
  • SenseTalkDougSenseTalkDoug ForumAdmin admin
    It sounds like your shift key is down. Please look carefully for anything earlier in your script that might be doing a typeText shiftDown without a corresponding shiftUp.
  • JonathanOSXJonathanOSX ForumAdmin admin
    You might also have the CapsLock key turned ON on your SUT.
Sign In or Register to comment.