Eggplant types way too fast

Hi,

I was trying to get Eggplant to type something, but sometimes the text gets cut off. For example, if I want to type "www.google.com", it sometimes types something like "w.google.com". Is there a good way to fix this?

Thanks,
Jason

Comments

  • depending on how you code, you may also use a wait statement if it all breaks loose as a result of the mistype. There are about as many ways to address this one as imagine can provide. I often had to slow down to wait for screen redraws, I remember you can set a slowdown for a specific section of code also. Todd might be along today even when it's a holdiay with some suggestions also.
  • JonathanOSXJonathanOSX ForumAdmin admin
    The best way to solve this is to slow down Eggplant's inherent delays when typing.

    Those are configurable from Eggplant->Preferences->Run Options->Keyboard.
    I would triple the time currently set for NextKeyDelay. This will affect the default time for any scripts that you run from that account.

    If you want to adjust it dynamically during a script (say if it's only slow during load tests) then you could use a script call like this:
    set the NextKeyDelay to 0.05
    
Sign In or Register to comment.